MikroTik Switch (CSS106-1G-4P-1S) Restart Every 6 Hours

I have installed LibreNMS and added my network devices, of these devices 15 are CSS106-1G-4P-1S MikroTik switches running swos. Every 6 hours we would have network disruption, we narrowed the problem to be these switches which would reboot every 6 hours (a few switches might stay up for 12 hours). When we shut down LibreNMS they all passed the usual time of reboot without rebooting or any disruptions.
LibreNMS on Ubuntu 16.04 in a ESXi 6.5 VM
network is a small WISP
number of devices monitored is about 80
main router is Mikrotik CCR1036-12G-4S
Please Advise
Thank You
I would like to add that there are is a gap in the main router when these reboots happen, this router has ~2K PPP connections and is connected to a radius server.

We run discovery every 6 hours so it’s something in that. You’ll need to run ./discovery.php -h HOSTNAME -d to see what the last module / snmp call was before it stops. You can then disable that module on all of these devices.

After that, go complain to Mikrotik as snmp queries shouldn’t case that.

Thank you for replying.
I ran ./discovery.php -h sw-h4 -d
But I didnt know which module the discovery stopped at, and the switch restarted.
i have turned the following modules off arp-table, cisco-vrf, ntp, vlans, wireless.
These are the last lines of the output:

./discovery.php sw-h4 2018-02-18 23:38:10 - 1 devices discovered in 8.132 secs
SNMP [29/0.86s]: Get[10/0.12s] Getnext[0/0.00s] Walk[19/0.75s]
MySQL [78/0.04s]: Cell[23/0.00s] Row[5/0.00s] Rows[45/0.01s] Column[1/0.00s] Update[1/0.00s] Insert[2/0.02s] Delete[1/0.00s]
RRD [0/0.00s]: Update[0/0.00s] Create [0/0.00s] Other[0/0.00s]

These swtches have watchdog enabled which is probably triggered by the discovery. I will turn all modules off and test he ones i need one by one.

You should pastebin the entire output.

I enabled the discovery modules one by one to find out which one caused the reboots, it turned out to be fdb-table module, I even disabled it and turned all the others on and all is fine, no reboots.
I will open this in the MikroTik forum as you have suggested.
When adding a new device the modules pre-specified are discovered, can i turn all of them off to avoid network load or is it negligible?
Thank you for your help

It’s negligible and mostly not an issue in discovery itself.