Minimum Supported PHP Version

I’m following the CentOS 7 installation instructions.

The packages referenced in the document are all PHP 7.0. Is this the minimum required version or can I go with the version provided in the CentOS default repositories and/or EPEL. I’m reluctant to add additional repositories that may not have the levels of validation that those repositories have.

I’m unable to find any specifics on required minimums and the only versions mentioned seem to be on that document.

Thanks for the information.

5.4 at present is supported for v1 but please please please just don’t. 7 is highly recommended due to the performance gains. However you should go for at least 5.6 seeing as that’s the minimum supported version by PHP itself.

5.6 is the min for v2 which is currently in early alpha stage.

Thanks for the quick response. The preference is to get to 7.0 quickly but I want to avoid a ton of custom repositories when deploying new appliances.

Thanks again.

I’ve got LibreNMS running perfectly on 5.6 But if you have the chance please listen to @laf’s advice and go with 7.0 right from the start.

You only need one repo to get it running. I’ve used webtatic