Monitor bind9 DNS application

i have FreeBSD11 server where i run my bind9 Cache DNS server, i already install snmpd in the server and i added to my LibreNMS system. everything seems working fine.
i would like to monitor the DNS therefore i just enabled bind app from edit as the following

but i am still get nothing in the graphs regarding the DNS usage
you kind help please.

Have you extended your snmpd.conf with the needed bind command and copied the file inplace?
https://docs.librenms.org/#Extensions/Applications/

1 Like

Exactly what Jarod2801 said, you need to follow the doc and set it up before you flip the switch in the web ui.

here is my modules, already enabled

i will follow the DOC
many thanks

@busy that dosnt do anything unless you have configured the app on the remote server.

https://docs.librenms.org/#Extensions/Applications/#bind9-aka-named

Just to give you info about my experience:
Try to use the “SNMP extend” way.

It’s easier than the agent way!

1 Like

This link doesn’t seem to work anymore?

https://docs.librenms.org/Extensions/Applications/#bind9-aka-named

Hi Guys,

Sorry to open an old thread, but I would like some help in getting BIND monitored.
I have followed the documentation as suggested, yet I still get NAN values in all the BIND application graphs

Below is my /etc/snmp/bind.conf file on the target DNS server running BIND9:

And below is what i see in LNMS:

BIND application is also enabled in the host settings in LNMS.

Any tips please ?

The file has to be named “bind” and not “bind.conf”.
Also it has to be executable.

You can check if bind is responding to the script my just running “./bind” via CLI when in folder “/etc/snmp”.

The output should look similar to this:

# ./bind
953295242,18497179,0,0,0,0,0,0,0,0,0,643,0,0,0,0,816885,91,0,0,0,0,0,75437997,0,0,0,8434,0,0,0,0,0,0,433,0,0,25022,0,75,0,0
3083049,371529,0,0,0,0,0,0,16914,0,0,397,0,0,0,0,1,40,0,3303594,0,0,0,1,0,0,0,0,0,0,0,0,0,0,433,0,0,379,0,0,0,0
1048082139,0,9618,113,0,0,1048081638,19,9618,1004028914,1022843670,25220963,3019443,17005,41016276,2009531,422,0,1048076822,38,0,4
6776473,0,3214581,0,730247,280,0,0,574,0,3272296,3562153,1107199,40,6732,40,1286075,1659534,243903,3398,21567,104,1046,0
177859080,2449700,48305664,87063168,0,1028389,392,583,848928610,215110,582093,655360,133120,133120
179,98,0,0,0,0,0,0,8,0,0,1,0,0,0,0,0,0,0,84,0,0,0,0,99,0,0,0,0,0,0,0,0,0,0,0,0,3,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
2042,296,2042,303
6776643,0,577,0,1,6776637,0,33835,0,738,0,0,0,0,0,0,0,6775899,574,0,0,33262,0,0,0,0,0,0,0,0,0,6,0,4,0,1

Hi Jarod,

Please see below the script name and result on the DNS server:

Looks good so far.

Graphs should now populate

Hi Jarod,

Unfortunately, they don’t. Please see below:

Not sure what am I doing wrong.

Anything you might advise to check ?

Have you restarted snmpd after editing?

yes sure. You mean on the target server ?
I will do it again now just to be sure.

[email protected]:/home/master# systemctl restart snmpd
[email protected]:/home/master# systemctl status snmpd
● snmpd.service - Simple Network Management Protocol (SNMP) Daemon.
 Loaded: loaded (/lib/systemd/system/snmpd.service; enabled; vendor preset: enabled)
 Active: active (running) since Mon 2021-10-04 09:47:17 UTC; 9s ago
 Process: 649943 ExecStartPre=/bin/mkdir -p /var/run/agentx (code=exited, status=0/SUCCESS)
  Main PID: 649950 (snmpd)
  Tasks: 1 (limit: 77138)
   Memory: 5.8M
   CGroup: /system.slice/snmpd.service
         └─649950 /usr/sbin/snmpd -LOw -u Debian-snmp -g Debian-snmp -I -smux mteTrigger mteTriggerConf -f -p /run/snmpd.pid

Oct 04 09:47:17 ns7 systemd[1]: Starting Simple Network Management Protocol (SNMP) Daemon....
Oct 04 09:47:17 ns7 systemd[1]: Started Simple Network Management Protocol (SNMP) Daemon..

Yeah, restart snmpd on the machine running bind9.
In before verify that snmpd is extended by the bind script as mentioned in the docs.

Above the is snmpd.conf

Try doing an snmpwalk to see if you can see any data or error messages. Something like:

snmpwalk hostname NET-SNMP-EXTEND-MIB::nsExtendOutput2Table

In my case I was seeing exactly the same issue as you describe and the snmpwalk gave a permission denied error. Snmpd was unable to open the stats file due to selinux blocking access.

Hi Dan,

Thanks for the tip.
Mine does not seem to complain about permissions.

I have done some fiddling the other day and got the graphs to change from -NaN to Zeros, but i hardly can believe this is correct since the DNS server in question is in fact in production.

I also see a couple of graphs with values, but they don’t seem to change. They got some value and it never changed after, so i’m not sure if they are being updated.

what do you think ?