Need assistance with Oxidized variables

Summary: CentOS7, NGINX with LibreNMS and Oxidized integrated using a local git repo on the VM for backups. I’m using the overrides in LibreNMS config.php to return groups to devices in Oxidized, with the groups configured in my Oxidized config file (working correctly)

How should I be configuring variables for groups, not globally? I don’t think I’m quite grasping how they should be configured. I have my config working for all but 2 switches, HPE Procurves, running Comware OS. Specifically that they aren’t elevating to the “enable” menu. The oxidized comware.rb has a variable that needs to be sent to elevate: :comware_cmdline . Notice in my below Oxidized config, I was able to configure the Cisco enable variable as part of the group settings. I did try the same thing for the comware using the cmdline variable, but that didn’t seem to work. I’m not even sure if that’s the correct way to declare variables in the config file for unique device groups.

Example of what my comwares are returning as part of their backups (oxidized is connecting and authenticating correctly, but not elevating to return show display/show run results).

Any insight would be appreciated

% Unrecognized command found at ‘^’ position.

My current Oxidized config file below [pastebin link for syntax] https://pastebin.com/NPJeqAhj


#username: username
#password: password
#model: ios
interval: 3600
log: ~/.config/oxidized/log
use_syslog: false
debug: false
threads: 30
timeout: 20
retries: 3
prompt: !ruby/regexp /^([\[email protected]]+[#>]\s?)$/

Listen on http://127.0.0.1.8888

rest: 127.0.0.1:8888
pid: ~/.config/oxidized/pid
vars: {}
groups:
cisco:
username: usernmae
password: password
vars:
enable: true
remove_secret: true
procurve:
username: username
password: password
comware:
username: username
password: password
models: {}
input:
default: ssh, telnet
debug: false
output:
default: git
git:
user: user
email: email
repo: /home/oxidized/.config/oxidized/configs
source:
default: http
http:
url: http://127.0.0.1/api/v0/oxidized
map:
name: hostname
model: os
group: group
headers:
X-Auth-Token: token
model_map:
cisco: ios
juniper: junos

With persistence I have prevailed, and I should have guessed the config is consistent with how the variables are declared under var_map when using router.db.

updated config that worked (for me and still requires correct YAML format)

groups:
comware:
username: username
password: password
vars:
comware_cmdline: Jinhua1920unauthorized (on some models this password is 512900)

How would a person do this if they have 1910 & 1920 models since they have the different _cmdline passwords?