Need assistance with updating LibreNMS


I am new to the Libre forums so please bare with me. Also I am not a Linux Admin - so I will have some basic questions for you.

We have a LibreNMS implementation that is old and we have tried to update it with no luck. Overall everything is working but we get alerts at random times that are sometimes false-positive and we are seeing a lot more of these occurrences than before. So I need to some advice and help from someone who might know how to fix this.

Here is the version we are on:

Version 1.69-1-gbc02ab3 - Mon Nov 02 2020 18:56:49 GMT-0700
Database Schema 2020_10_21_124101_allow_nullable_ospf_columns (188)
Web Server Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/7.2.34
PHP 7.2.34
Python 3.6.8
MySQL 5.5.68-MariaDB
Laravel 7.28.3
RRDtool 1.4.8

Running Validate Config from GUI give me these errors:

** I ran ./ command and it does an update but doesn’t really update anything.

[libre-admin@slvlibrenms librenms]$ sudo ./
Re-running /opt/librenms/ as librenms user
Updating SQL-Schema OK
Cleaning up DB OK
[libre-admin@slvlibrenms librenms]$

There is a lot I need to do but first thing I would really like to do is make LibreNMS stable and apply new updates to see if my current version can be more stable.

Any assistance, help, thoughts… etc - would be really appreciated.



First thing first, have you tried running those fixes from your validate config?

via cli run each of those fix commands
They are just setting appropriate permissions on specific directory’s


Just ran all the commands from CLI and no errors. Validate Config show this:

FYI - from what I have been told - we have ran these commands before and Libre some how reverts back and we see the same output of Validate Config/commands being listed after some time. Not sure why this would be.

Is there a way to apply updates now? What commands do I run? Maybe I need run the commands and apply updates back to back. Just thinking out loud.



We used to have similar issues however it seems to have resolved itself.
I’m not 100% sure why but it may have something to do with trying to run ./validate as a root user as that may change some of the permissions away from your librenms user on those directories.

So for all librenms related commands always run under the librenms user context commands I use are below:
sudo su librenms
cd ~
Running the ./daily (as the librenms user) should pull the latest version of librenms (you’re version looks like its from 2020)
the ./daily should conduct the following:

I ran the command again:

I only see two things being updated. Not sure why other updates are not being applied/updated. Could there be a setting that has been changed and commented out?


Via the web interface can you check that daily updates arent disabled? (ref: Updating - LibreNMS Docs)
Global Settings > System > Updates

The other option that may be set that disables updates is within the config.php file
it has a line something like below:

# Uncomment the next line to disable daily updates
#$config['update'] = 0;

obviously if that is uncommented then that will be disabling updates

[chintanpintu], you must run LibreNMS scripts like or validate.php only as librenms user - not as root.
All errors, that you have seen after running Validate - is a commands that you must apply as root user: by this commands you fix permissions in librenms directory for librenms user.
Before run daily/validate - log in as librenms user:
su - librenms

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.