Need to disable writing into rrd file

Hi All,
I want to know if there is mechanism by which we can disable timeseries data collection. reason being I dont want those graphs in Librenms and those large RRD files to be generated. Any suggestions ?

You could disable various modules (such as ports module) so you would not get the RRD files for the ports.

You could also just not run the pollers.

What would you use LibreNMS for if not to gather time series data?

Hi @pjchilds I am only using LibreNMS for alerting purpose that too getting forwarded to other system via webhook. now the problem here is the timeseries data that we dont want. How I can disable that feature only so that the unnecessary rrd files wont get created and disk utlization would also remain low.


I don’t think there is an option for that.

You could write a dummy rrdcached server that just said ‘OK’ for every operation.

Or you could try setting the location of the rrdtool binary to /bin/echo

Or you could remove write permissions to the rrdtool directory

Either or all of these suggestions might not work and might create all sorts of errors

Thanks for the response @pjchilds . I am using Docker setup currently. Could you help me how should I try dummy rrdcached here.

Just to update @pjchilds I tried setting rrdtool bin to bin/echo and it actually worked. no issues observed in polling as of now and I can see no rrd files being created. Will keep a watch and see if alerting is working fine :slight_smile: Thanks

Is there anything I should keep watch/check that you suspect.

Hi @pjchilds I was also able to crack down the polling option below

device:poll [options] [–]

-x, --no-data Do not update datastores (RRD, InfluxDB, etc)

Updated the LibreNMS/ with this option and I am able to stop rrd update :slight_smile: