New Transport - Failed to process alert transport

Hi all,

I’m new to LibreNMS. After sorting through polling and adding devices, I’m now stuck on setting alert notifications. I’ve configured the Email Option in General Settings to try to use mail, sendmail and SMTP with no luck.

When I attempt to add a new mail transport and click “Save Transport” it returns the “Failed to process alert transport” error. Most of what I’ve found looking for a solution is when the error is shown when a transport already exists. I can’t get that far. I attempted to quickly set up an IRC transport and a Pushover transport, but they both threw the same error.

I appreciate any insight you have for where I’m missing something or which logs I can maybe look at.

$ ./validate.php

Component Version
LibreNMS 1.60-52-gc136e1ad6
DB Schema 2020_02_10_223323_create_alert_location_map_table (159)
PHP 7.2.24-0ubuntu0.18.04.3
MySQL 10.1.44-MariaDB-0ubuntu0.18.04.1
RRDTool 1.7.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.9.3
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
$

I believe the issue was tied to some of the DNS settings for the host/server name. I resolved other issues and I found I was able to add a transport option as well.

I agree, I was getting the same error, switched to the fqdn instead of a short name and it worked, thanks @tyman00

I seem to be experiencing the same issue. I am unable to create a new Transport after configuring my email and SMTP settings. Are you able to detail the steps you took to resolve this issue?

You solve this?

Not sure if anyone find this useable, but I fixed it on my setup - simply by using FQDN instead of just servername

That is: use “server.domain.home” instead of “server”

CU

I’m having the same issue here on a new install. Can someone provide more details on where I change the servername setting?

I experienced the same issue but it was my installation configuration error.
If you did install manually, then please check and modify “server_name librenms.example.com;” section on your NGINX configuration.
Installing LibreNMS - LibreNMS Docs