NFSen integration no graphs

I’ll try piggy-backing on this…I’ve installed NFSEN independently of LibreNMS / different machine with RRD’s exported and mounted on LibreNMS machine via fstab.

I get the “netflow” tab on the devices and I get statistics but no graphs.

I’ve moved your topic to a new one.

Are you running rrdcached? Does librenms have read permissions for that mount?

thank you. I’m running RRDCACHED on my librenms box but not on the nfsen box. I could set it up on the nfsen box if it would make everything easier.

good thought on the librenms user…I didn’t even think of that…take pity on me I’ve been a windows guy for so long. On my nfsen box I have the exports set to this:

opt/nfsen IP_OF_MY_LIBRENMS_HOST/32(rw,nohide)

which, if I understand the basics of NFS, it doesn’t matter which UID from MY_LIBRENMS_HOST mounts /opt/nfsen - it should have read and write.

on my librenms machine, I have this set in fstab

my_NFSEN_IP:/opt/nfsen /media/nfsen nfs rsize=8192,wsize=8192,timeo=14,_netdev 0 0

in my librenms config I have the following:

$config['nfsen_enable'] = 1;
$config['nfsen_split_char']   = '_';
$config['nfsen_rrds'][]   = '/media/nfsen/profiles-stat/live/';
$config['nfsen_rrds'][] = '/media/nfsen/profiles-stat/';
$config['nfsen_base'][] = '/media/nfsen/';
$config['nfdump'] = '/usr/bin/nfdump';
$config['nfsen_last_max'] = 153600;
$config['nfsen_top_max'] = 500;
$config['nfsen_top_N']=array( 10, 20, 50, 100, 200, 500 );
                            '300'=>'5 minutes',
                            '600'=>'10 minutes',
                            '900'=>'15 minutes',
                            '1800'=>'30 minutes',
                            '3600'=>'1 hour',
                            '9600'=>'3 hours',
                            '38400'=>'12 hours',
                            '76800'=>'24 hours',
                            '115200'=>'36 hours',

also, we do use IP for all of our librenms targets, so I did create a pointer for 10_10_11_1 on the nfsen box for

No, you dont have to install rrdcached on nfsen box.

Does your rrdcached run with -B flag? if yes, remove it. (Capital B)

1 Like

I wasn’t sure how to take off the -B flag. I stopped rrdcached and then I disabled it in my librenms config.
Graphs are working…but rrdcached isn’t. hahaha. I’m figuring it’s in init.d somewhere but I haven’t dug yet.

systemctl status rrdcached
Take the Loaded: line
Edit that file (the -B will be probably there)

perfect…that was it. Odd thing is the /etc/init.d/rrdcached file had the options greyed out almost like they weren’t enabled and were comments. Thank you so much for the assistance, very much appreciated.