Nfsen intigration

I configured nfsen and nfdump I followed the guide Librenms NFSen Setup

So I got everything configured NFSen is getting, and graphing data. My issue is NFSen will not allow “-” in a source name. Will creating a symbolic link like at the end of the article work for this like it would for an IP Address?

Example:
NFSen Source: MDF0101
Librenms Host Name: mdf-01-01

Symbolic Link:
ln -s MDF0101.rrd mdf-01-01.rrd

Thanks in advance.

Yes, it should work with a symbolic link as it was an ip address

I think I missed something then because I have the netflow tab under the device but there are no graphs also checking “/opt/librenms/rrd/mdf-01-01/” I dont find an actual .rrd file with the device name.

These are my config.php settings for nfsen.

$config[‘nfsen_enable’] = 1;
$config[‘nfsen_split_char’] = ‘_’;
$config[‘nfsen_rrds’][] = ‘/data/nfsen/profiles-stat/live/’;
$config[‘nfsen_rrds’][] = ‘/data/nfsen/profiles-stat/live/’;
$config[‘nfsen_suffix’] = “_domain_com”;

nfsen is getting data because the nfsen graphs are showing data and I can list data.