No active polling method detected

Hi Guys,

I did all the possible search and couldn’t find the solution, the issue disapears after I do the command " ./ 16" but comes back again after some minutes. seems the scheduler for polling is not working but I don’t know how to fix it :slight_smile:

bash-4.4$ ./validate.php

Component Version
LibreNMS 24.6.0-51-g991424e54 (2024-07-09T23:02:40+02:00)
DB Schema 2024_04_29_183605_custom_maps_drop_background_suffix_and_background_version (294)
PHP 8.1.29
Python 3.6.8
Database MariaDB 10.3.39-MariaDB
RRDTool 1.7.0
SNMP 5.8

[OK] Composer Version: 2.7.7
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQL and PHP time match
[FAIL] No active polling method detected
[OK] Dispatcher Service not detected
[OK] Locks are functional
[FAIL] No active python wrapper pollers found
[OK] Redis is unavailable
[OK] rrd_dir is writable
[OK] rrdtool version ok
[WARN] Your local git contains modified files, this could prevent automatic updates.
You can fix this with ./scripts/github-remove
Modified Files:

I see the following error on the cron job :slight_smile:

crond.service - Command Scheduler
Loaded: loaded (/usr/lib/systemd/system/crond.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2024-07-10 15:39:29 CEST; 2h 18min ago
Main PID: 1012 (crond)
Tasks: 1 (limit: 49015)
Memory: 162.9M
CGroup: /system.slice/crond.service
└─1012 /usr/sbin/crond -n

crond[1012]: (system) RELOAD (/etc/cron.d/librenms)
rond[1012]: (/opt/librenms/cronic) ERROR (getpwnam() failed - user unknown)
(/opt/librenms/cronic) ERROR (getpwnam() failed - user unknown)

*/5 * * * * librenms /opt/librenms/cronic /opt/librenms/ 16

Out of curiosity is your polling working regardless? I too get the same error but it constantly comes and goes but I have no polling issues, all graphs are fine. My poll time is currently at 79 seconds and i have this idea that if its more than 30 seconds it spits out this error.

The below pic will flick between OK and Fail for wrapper pollers and active polling method


Does the librenms user exist on your system? It looks like crond is saying it is trying to run the poller wrapper with a user account that doesn’t exist on the system.

yeah my issue is that the polling doesnt happen unless I trigger it manually on the CLI

yes it is exists, i fixed that but still the same issue unfortunately

issue solved, i had a parallel installaton running and had to edit another config.php for maria db access. thank you


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.