No data in Graph widget

Greetings.

During the holiday season, our LibreNMS ran out of diskspace. After cleaning up the mess, everything seems to work just fine, except the graphs we have on our Dashboards. All other widgets works just fine, but there is no data in the graph widget, its just white. If I go to the actual graph on one of the switches, it is there, and working just fine.

I cannot find anything related to this in the librenms logfiles.
What can be causing this?

====================================

Component Version
LibreNMS 1.58.1-71-g17b3f84
DB Schema 2019_12_01_165514_add_indexes_to_mpls_lsp_paths_table (152)
PHP 7.2.16-1+ubuntu16.04.1+deb.sury.org+1
MySQL 10.0.38-MariaDB-0ubuntu0.16.04.1
RRDTool 1.5.5
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 1.9.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

@louis I think you replied to the wrong topic :wink:

Anyone?

We also have a custom website creating graphs from LibreNMS, using the API.
API authentication seems to work just fine, but no graphs are drawn, and we get errors like this:
Error getting device with id: 25

Does the graph widget use the LibreNMS API to create graphs?

What are you picking to make the graph widget? Can you send a screenshot?

I have tried different values, and from different switches and routers, without getting any graphs. All I see is “generic-graph”, and then it turns blank.

Here is some screenshots

Here is the config I have used for two years, before this issue occurred, its monitoring of a port-channel on our nexus7k:


Here is how the widget looks after I save config:

Here is the graph from the same interface if I browse to the nexus -> Ports -> :

So as you can see, the widget for some reason doesn’t collect the data from the graph.

have you tried removing the widget saving the dashboard and then adding it back?

Yes. I have also created new dashboard and adding the widget, with the same result

Open console (F12) and refresh dashboard.

Do you get any error?

The graphs are back!

After receiving 1.59-22-gb44875f last night, the graphs are back :slight_smile:

I’m happy it’s work for you now but it’s strange because nothing in those commits would affect the issue you were having.