No notification for failured PSU

Tags: #<Tag:0x00007f84a81bafd8> #<Tag:0x00007f84a81baee8>

Looking for help regarding network device redundant PSU failure.
Alert Rule is not working, despite the fact failure PSU can be seen in database.
Alert Rule SQL looking as the following:

SELECT * FROM devices,sensors WHERE (devices.device_id = ? AND devices.device_id = sensors.device_id) AND sensors.sensor_current = 0 AND sensors.sensor_class = “voltage”

Double check in the db directly showing the following:

SELECT * FROM devices,sensors WHERE (devices.device_id = 18 AND devices.device_id = sensors.device_id) AND sensors.sensor_current = 0 AND sensors.sensor_class = “voltage” \G

                 type: network
               serial: FXS2431Q0FL
                 icon: cisco.svg
         poller_group: 0
 override_sysLocation: 0
                notes: NULL
port_association_mode: 1
            max_depth: 1
       disable_notify: 0
            sensor_id: 17044
       sensor_deleted: 0
         sensor_class: voltage
            device_id: 18
          poller_type: snmp
           sensor_oid: .1.3.6.1.4.1.9.9.91.1.1.1.1.4.6
         sensor_index: 6
          sensor_type: cisco-entity-sensor
         sensor_descr: Power Supply Module 0 - PEM Vin P0/2
                group: NULL
       sensor_divisor: 1
    sensor_multiplier: 1
       sensor_current: 0
         sensor_limit: 264.5
    sensor_limit_warn: NULL
     sensor_limit_low: 195.5
sensor_limit_low_warn: NULL
         sensor_alert: 1
        sensor_custom: No
     entPhysicalIndex: 6

entPhysicalIndex_measured: 3
lastupdate: 2021-08-02 14:10:25
sensor_prev: 230
user_func: NULL

Sensor_current is: 0 so IMO this should trigger a an alert rule. But it isn’t

====================================

Component Version
LibreNMS 21.7.0-31-g9557cccb6
DB Schema 2021_07_06_1845_alter_bill_history_max_min (212)
PHP 8.0.3
Python 3.5.3
MySQL 10.6.2-MariaDB-1:10.6.2+maria~stretch
RRDTool 1.6.0
SNMP NET-SNMP 5.7.3

====================================

[OK] Composer Version: 2.1.5
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[FAIL] You have no timezone set for php.
[FIX]:
https://php.net/manual/en/datetime.configuration.php#ini.date.timezone
[WARN] Your install is over 24 hours out of date, last update: Sat, 31 Jul 2021 16:26:57 +0000
[FIX]:
Make sure your daily.sh cron is running and run ./daily.sh by hand to see if there are any errors.

Screenshot:

In the web UI, in your alert rule, you may need to add the PSU in question to the box “Match devices, groups, and locations list”.

Another troubleshooting step: you can go to the device page log, (Device → Logs) and see if the alert you set appears in the log. As well as if the current = 0 also appears in the log.

Hey skwang, thank you for your reply.
Ive already tried out with the match devices setting, but no difference though.
What i can see under logs is that the state change has been detected, but no alerting:

What is odd is that i can see an alerting for other devices “voltage” state, which i don’t want to see as it is irrelevant for me: Te1/1/1 Supply Voltage

[
{
“device_id”: 16,
“inserted”: “2020-08-19 20:43:12”,
“hostname”: device_name",
“sysName”: “device_name”,
“ip”: null,
“overwrite_ip”: “”,
“community”: “xxxx”,
“authlevel”: null,
“authname”: null,
“authpass”: null,
“authalgo”: null,
“cryptopass”: null,
“cryptoalgo”: null,
“snmpver”: “v2c”,
“port”: 161,
“transport”: “udp”,
“timeout”: null,
“retries”: null,
“snmp_disable”: 0,
“bgpLocalAs”: null,
“sysObjectID”: “.1.3.6.1.4.1.9.1.2694”,
“sysDescr”: “Cisco IOS Software [Fuji], Catalyst L3 Switch Software (CAT9K_LITE_IOSXE), Version 16.9.5, RELEASE SOFTWARE (fc1)\nTechnical Support: http://www.cisco.com/techsupport\r\nCopyright (c) 1986-2020 by Cisco Systems, Inc.\r\nCompiled Thu 30-Jan-20 18:08 by mcpre”,
“sysContact”: null,
“version”: “CAT9K_LITE_IOSXE 16.9.5”,
“hardware”: “C9200L-48T-4X”,
“features”: “Fuji”,
“location_id”: 2,
“os”: “iosxe”,
“status”: 1,
“status_reason”: “”,
“ignore”: 0,
“disabled”: 0,
“uptime”: 38825201,
“agent_uptime”: 0,
“last_polled”: “2021-08-05 20:15:25”,
“last_poll_attempted”: null,
“last_polled_timetaken”: 19.65,
“last_discovered_timetaken”: 13.57,
“last_discovered”: “2021-08-05 18:53:03”,
“last_ping”: “2021-08-05 20:15:25”,
“last_ping_timetaken”: 18.9,
“purpose”: “”,
“type”: “network”,
“serial”: “xxxxxx”,
“icon”: “cisco.svg”,
“poller_group”: 0,
“override_sysLocation”: 0,
“notes”: null,
“port_association_mode”: 1,
“max_depth”: 2,
“disable_notify”: 0,
“sensor_id”: 12759,
“sensor_deleted”: 0,
“sensor_class”: “voltage”,
“poller_type”: “snmp”,
“sensor_oid”: “.1.3.6.1.4.1.9.9.91.1.1.1.1.4.1116”,
“sensor_index”: “1116”,
“sensor_type”: “cisco-entity-sensor”,
“sensor_descr”: "Te1/1/1 Supply Voltage ",
“group”: null,
“sensor_divisor”: 10,
“sensor_multiplier”: 1,
“sensor_current”: 0,
“sensor_limit”: 0,
“sensor_limit_warn”: null,
“sensor_limit_low”: 0,
“sensor_limit_low_warn”: null,
“sensor_alert”: 1,
“sensor_custom”: “No”,
“entPhysicalIndex”: “56”,
“entPhysicalIndex_measured”: “ports”,
“lastupdate”: “2020-08-19 20:45:20”,
“sensor_prev”: null,
“user_func”: null
}
]

I just want to give a heads-up here as i have noticed that i got a notification due to auto-update on to version
21.9.0-8-g0d499b538 - Mon Sep 20 2021 02:28:42 GMT+0200]
But since then the PSU has been again powered on, but the notification doesn’t change. (again)
I think there might be an issue with the poller?