No ports on Nexus N9K-93180YC-FX (9.3.7)

When I try to view the ports of the switch (Via device/ports), I can´t see any ports.

However, When I go to settings for the device and take a look at ports I see them.

From what I can tell, all looks fine with validate and snmp-walk. I doesn´t matter what browser Im using.

Output from validate.php

====================================

Component Version
LibreNMS 22.9.0
DB Schema 2022_09_03_091314_update_ports_adsl_table_with_defaults (246)
PHP 8.1.10
Python 3.8.10
Database MariaDB 10.3.34-MariaDB-0ubuntu0.20.04.1
RRDTool 1.7.2
SNMP 5.8
====================================

[OK] Composer Version: 2.4.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK]
[OK] Database schema correct
[OK] MySQl and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[OK] rrd_dir is writable
[OK] rrdtool version ok

Output from discovery: https://p.libren.ms/view/d2e89dcb
Output from poller: https://p.libren.ms/view/90caacd7

Worth mentioning, I deleted the device and then added it again. In the beginning, I can see the ports, But then they disappear since they loose their port description when its polled.

Purge deleted ports and check

image

I am not seeing that issue on the 93180YC-FX running 9.3.9. I have several of them running as vPC vxlan leaves and all are showing full ports list of ethernet, port-channels, vlans, and the nve1 interface.

I tried purging deleted ports, but as it started to rediscover and poll the device. The ports disapeared again. Present in deleted with port description? I cant understand why its being deleted then…

I notice that status changed is a year, but its recently purged.

try capturing the logs from opt/librenms/logs/librenms.log while accessing the page

Regarding Status changed, its nothing but when was link flapped. you can cross check with show interface output from device

Are you using multiple pollers? I just started a new setup and let it run for a bit without setting up redis and breaking up the devices into different poller groups. I had 3 pollers all hitting the same 48 port nexus 9K with a dozen fex hanging off of it.

My ports were disappearing and total traffic was displaying multiple tbps of throughput when I should have only had 50-60 gbps on that switch.

Configuring redis and setting up dispatcher service corrected everything.

I see almost the same issue on C93180YC-FX running NXOS: version 9.3(7). Discovery finds ports, and adds them with IP and description. When poller runs, descriptions and IPs disappear.
Under port settings the state is missing. Looks exactly like your screenshot. My interfaces are still showing after the poller has run, probably due to existing data, but statistics are missing for most interfaces. On some interfaces there are 90% holes in the graphs.

I saw this issue on 2 of 6 switches all running the same 9.3(7) nxos.
I have tried to kill the snmpd in the switches without success.
The current traffic counter in Librenms updates and is correct, but no data in the graphs.
9.3(7) is a bad release since it has bad firmware on the SSD which can put the SSD in read-only mode. I had to have one switch replaced due to that issue. I will try to upgrade to 9.3(10) when I get a window to do it.

I have not upgraded yet, but on one of the switches with this issue, I messed around a log with the configuration last night. Deleted all Portchannel interfaces not in use, and that seems to have fixed the issue. It must have restarted something.