Not able to add devices

When asking for help and support, please provide as much information as possible. This should include:

  • Steps to reproduce an issue.
  • The output of ./validate.php

If it’s an issue with the WebUI then please consider including a screenshot and the browser version you are using.

If you are having troubles with discovery/polling include the pastebin output of:

./discovery.php -h HOSTNAME -d | ./pbin.sh
./poller.php -h HOSTNAME -r -f -d | ./pbin.sh

If you need to post any text longer than a few lines, please use a pastebin service such as https://p.libren.ms using non-expiring pastes.


after adding all details coorectly, then also it is showing like.Anyone can help whats my mistake

Is your instance hosted on another network? Behind a firewall?

I will assume not and it’s adjacent to the target host - more likely that SNMP is not installed and/or configured on the target

1 Like

No the instance is in same network

snmp also enbled for that system

Are you able to do snmpwalk from the librenms OS, in a terminal, to the device you want to add?

1 Like

NO. Can you please suggest for snmp communication what exactly should i need to do?

Hi,

It’s not on LibreNMS side then.
You can try the classic stuff to debug a service that cannot communicate.
Source and target Firewall / ACL, check with ss / netstat if the target get the port 161/udp in the listening state, can you ping, and so on

I am trying to add pfsense server.


See my pfsense snmp configuration.I am able to ping that machine from my libre os. So what configuration should i need to change?

Hello @JyotiCyber

Do you have SNMP installed and configured on the destination host?

If the above is affirmative. What version of SNMP would you be using?

Is the remote host a switch, router, server,…? With what operating system?

I await your response to try to help you.

Hello @aleferrari ,

Yes, I have installed SNMP inside the Librenms.
It’s SNMP v2c/
It’s a firewall inside my network.

Can you please help me out.

On the firewall, I would check:

  • SNMP running as active service
  • SNMP with community string correctly configured
  • SNMP without remote IP access filtering
  • SNMP configured for port 161
  • open port 161 on the firewall (attention to this) towards your network

On the LibreNMS host:

  • I would perform SNMP tests with the “snmpwalk” command before trying to add the device in LibreNMS again (it will return more information regarding the problem)

Example:

Command line for host 192.2.2.116 with SNMP v2c…

snmpwalk -v 2c -c mycommunity -r 3 -t 2 192.2.2.116 iso.3.6.1.2.1.1.1.0

Output…

iso.3.6.1.2.1.1.1.0 = STRING: "HPE OfficeConnect Switch 1920S 24G 2SFP JL381A, PD.02.19, Linux 3.6.5-375bd0e8, U-Boot 2012.10-00118-g3773021 (Oct 11 2016 - 15:39:54)"

By following these steps I have been able to solve problems with symptoms similar to yours.

Regards

apart from this pfsense , are you able to add other devices ?

if its issue with only pfsense, check the settings mentioned by aleferrari.
in addition to it, also check the interface binding settings under pfsense SNMP settings

by default, pfsense blocks SNMP on WAN interface

1 Like

No, I was trying to add fortigate. The same issues arrises for that also

FortiGates need a few things in order to poll them.

  • Agent
  • Community (and source-ip should it be necessary, depending on setup)
  • Interface allowaccess

Firstly, enable the SNMP Agent, you can find this on the CLI with the following:

config system snmp sysinfo
show full

You need to set the status to enable if it’s not already.

On the UI you can navigate to System - SNMP and you’ll see it there too.

Then create a community or user (I will use v2c in this example, as well as disabling v1)
source-ip is important as the FortiGate will follow its route table to return packets, it may not be applicable in your use case as you said they were in the same segment/L2, but worth mentioning for future reference.

config system snmp community
    edit 1
        set name "v2example"
        config hosts
            edit 1
                set source-ip <IP to use>
                set ip <NMS IP>/32
            next
        end
        set query-v1-status disable
        set trap-v1-status disable
    next
end

On the UI you can navigate to System - SNMP and you’ll see the same detail there. You cannot set source-ip from the UI though.

Set SNMP allowaccess on the interface you are trying to poll. I have appended it in this example. Using ‘set’ as you will likely see it on the CLI will replace the configuration, unless you specify everything in a single line of course, eg. set allowaccess ping snmp

config system interface
    edit "example_interface"
        append allowaccess snmp
    next
end

On the UI you can find this under Network - Interfaces. Go into the interface and review Administrative Access, enable SNMP.

I hope this helps