Not able to go to the librenms folder via command line

I I downloaded the LibreNMS for my virtual Box and it is working perfectly. I also created the weathermap.
During the test I created many weathermaps and I wanted to delete the previous one.

I have to go to the folder name /opt/librenms/html/plugins/weathermap/config to delete the old config.

I tried directly cd /opt/librenms/html/plugins/weathermap/config but it did not allowed me to do so. Thus I did as below:
root:~$cd /opt
root:/opt$cd librenms
root:~$ _
soon i do cd librenms i go out and go to the root
can any one know what actually is the issue? and how to get the solution of this issue?

Have you tried sudo su librenms and then attempted your action?

Hello @Prakash_Chhetry

Please run a

ls -l /opt | grep 'librenms'

and paste the output as response here


It’s a capital W in Weathermap. I’d honestly suggest learning some basic linux skills alongside LibreNMS, it will really help in debugging these things.

Hello aleferrari,
Thankyou for your reply.
Sure I will run the above command and try paste the output.


Hello Laf, Thankyou for your reply, but i think you are so hurry to reply without reading/knowing the problem…

Helo Chadwick,
Thankyou for your reply,
Ofcourse I tried with the sudo command but it didnot worked

Not really, you can’t cd into the directory because you are missing the capital W from Weathermap.

1 Like

What I mean is that you may need to change to the librenms user in order to do what you are attempting.

sudo su librenms = sudo - run command in elevated state, su - switch user, librenms - the librenms user. Your user may be called something else, but this is NOT the root user.


@Chadwick Thankyou so much, I was able to go to the librenms folder using sudo su.

Happy to have helped.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.