Not showing graph on port at librenms

Hi ! anyone meet this issue the same me,
due i check to port tab it seem not showing graph

Click one of the graphs, right click on the broken part and copy the image url, paste into a browser and add &debug=true to the end of it, it should produce some text which might tell you what’s going on.

If not, click one of the images and click show rrd command and see what that says.

If not, check your web server and librenms logs.

1 Like

I have a similar issue that started in the last week. Was on vacation so not 100% on when the graphs stopped. When I add &debug=true to my image URL it shows properly. All of my graphs are broken in the same way and all work when I append that to the URL.

My nginx and librenms logs don’t show anything that stands out.

I was on Alma Linux 8. It broke when php was upgraded from 8.1.24 to 8.1.27. PHP 8.1.24 was removed from the repo so no easy downgrade option. I tried upgrading to 8.2 and 8.3 and nothing worked.

Instead of troubleshooting this I decided to move to a Ubuntu server as it seems to be the preferred option for LibreNMS. Everything is working as expected now.