Nsx-t datacenter MIBs

Hello,

I tried adding my NSX-T Manager to librenms, but unfortunately not much shows up. It appears that the VMware MIBs are a bit outdated.

librenms/mibs/vmware at master · librenms/librenms (github.com)
→ Dated from a few years back, and no trace of VMWARE-NSX-MIB.mib

The latest version is 7.11, available here (lower right): VMware Knowledge Base

I don’t really know if something else must be done afterwards in librenms to use this new MIB?

Thanks and kind regards,

Hi

I’m just facing a similar target,
I would like to monitor with SNMP some networking parameters of the NSX-T Edges.
Did you do any progress during these months ?

Thanks, regards
I.

PS: on the link you reported of the KB 1013445,
you could download the package “VMware-mibs-7.7.0NX-18507376.zip”,
where the “VMWARE-NSX-MIB.mib” is present and also updated (202202140000Z)


I just tried to do the first step (I think …) to add a new entity into LibreNMS, like NSX-T edges.
Here below the output obtained using the new-os script.
I think it will be necessary to manually arrange the empty yaml file generated in the directory “discovery”,
I will try to do it after an examination of the other present in the same dir.



[email protected]:/opt/librenms/scripts# ./new-os.php -h 179 -o vmware-nsx -t vmware-nsx -v vmware

sysDescr: NSX-T 1.0.0 generic build 0000 VMware, Inc x86_64

sysObjectID: .1.3.6.1.4.1.6876.4.10

We already detect this device as OS vmware-esxi type, do you want to continue to add sensors? (Y/n) Y

ctrl+c to exit now otherwise please enter the MIB name including path (url is also fine) for us to check for sensors: /opt/librenms/mibs/vmware/VMWARE-NSX-MIB

Unable to find a matching object identifier for ".*Table$"

Failed to create new discovery file /opt/librenms/includes/definitions/discovery/[email protected]:/opt/librenms/scripts#

[email protected]:/opt/librenms/scripts#

Hi all

I tried to enhance the attention on this topic opening the new discussion: VMware NSX-T and LibreNMS integration