Only Poll IfHighSpeed

Tags: #<Tag:0x00007f064f95c0c0> #<Tag:0x00007f064f963fa0>

I have been getting false alarms on libre for my cisco device with threshold being exceeded.

When I check I see that in the IF table cisco router reports Interface as 4Gig instead of 10Gig. However if we poll IfHighSpeed the reply is correct.

snmpwalk -v2c -c community -OQUs  -m IF-MIB -M /opt/librenms/mibs X.X.X.X ifSpeed                          
ifSpeed.21 = 4294967295
ifSpeed.22 = 4294967295
ifSpeed.23 = 4294967295
ifSpeed.25 = 4294967295
ifSpeed.26 = 4294967295
ifSpeed.27 = 4294967295


snmpwalk -v2c -c community -OQUs  -m IF-MIB -M /opt/librenms/mibs X.X.X.X ifHighSpeed
ifHighSpeed.21 = 100000
ifHighSpeed.22 = 100000
ifHighSpeed.23 = 100000
ifHighSpeed.25 = 100000
ifHighSpeed.26 = 100000
ifHighSpeed.27 = 100000

Under device settings port capacity is actually correct:

but on eventlog I can see the port capacity keeps changing:

It looks like we get the port capacity change when the highspeed gets Null from SNMP, which makes me think that librenms fallbacks to ifspeed when ifhighspeed is null.

Is there a way to force librenms to only poll ifHighSpeed to prevent these false alarms from happening on selected devices?

/opt/librenms/validate.php

Component Version
LibreNMS 1.58
DB Schema 2019_08_10_223200_add_enabled_to_users (147)
PHP 7.2.11
MySQL 10.1.37-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.9.1
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct