OVA Installation - Device Groups "Whoops, looks like something went wrong. Check your librenms.log. "


I have recently installed the OVA version of LibreNMS ( output from my daily.sh and validate.php is below ):

[librenms@localhost ~]$ ./daily.sh
Updating to latest release OK
Updating Composer packages OK
Updating SQL-Schema OK
Updating submodules OK
Cleaning up DB OK
Fetching notifications OK
Caching PeeringDB data OK
[librenms@localhost ~]$
[librenms@localhost ~]$
[librenms@localhost ~]$
[librenms@localhost ~]$ ./validate.php

Component Version
LibreNMS 1.54
DB Schema 2019_07_03_132417_create_mpls_saps_table (139)
PHP 7.2.19
MySQL 5.5.60-MariaDB
RRDTool 1.4.8

[OK] Composer Version: 1.8.6
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct
[librenms@localhost ~]$ ^C
[librenms@localhost ~]$

I have successfully added about 60 or so devices, most of them belong in 3 different categories ( VMware, Servers, IOS), so I went to the following URL: {server ip}/device-groups to try and group these devices. The web page pulls up fine…

When I attempt to click “+ New Device Group”, I get the following error:

I did some research here on the forum, and I found the following links:

Very simliar issues, so I got the librenms.log and found the same error:

[2019-08-01 21:57:27] production.ERROR: file_put_contents(/opt/librenms/cache/devices_relationships.cache): failed to open stream: Permission denied {“userId”:1,“exception”:"[object] (Er
rorException(code: 0): file_put_contents(/opt/librenms/cache/devices_relationships.cache): failed to open stream: Permission denied at /opt/librenms/LibreNMS/DB/Schema.php:173)

I have been pulling my hair out trying to change the permissions on the “devices_relationships.cache” file so this page will load. I have tried the following:

sudo chown -R librenms:librenms /opt/librenms/cache
chown librenms:librenms devices_relationships.cache

Nothing I am trying is working. I have restarted the server after I attempted to change the permissions. The current permissions are as follows:

[librenms@localhost cache]$ ls -l
total 240
-rwxrwxrwx. 1 librenms librenms 0 Aug 1 21:44 devices_relationships.cache
-rw-r–r–. 1 librenms librenms 243884 Aug 1 22:20 os_defs.cache

What else do I need to do?



I am encountering the exact same issue.
Same errors as well, tried everything regarding permissions but to no avail.

Did you manage to find a solution?

Yes, I managed to fix it.

On the CentOS build the SELINUX security settings are preventing the .cache file from running under the right process context. Have a look below at what we did to fix it:


Hopefully this will help someone else out who is running CentOS.

You have to add the " chcon -t httpd_sys_rw_content_t devices_relationships.cache" httpd process to the SELinux Context then poof the page starts to work again.

The other option ( nuclear option ) is to totally disable SELinux on CentOS7.


1 Like

YES! Thank you! I am using the downloaded VM and couldn’t get groups to work. This was the solution. Freakin’ selinux again.

That was it, thanks for sharing your solution!