Oxidized configs not loading in LibreNMS (centos7/nginx)

This is a bit weird since I had this working on a test server before building a production server.

Installed LibreNMS + Oxidized on local host. Enabled Oxidized support via the External settings menu, pointing to localhost (http://127.0.0.1:8888)

Generated an API token for the LibreNMS admin user, used that token under the Source configuration settings in Oxidized config per LibreNMS documentation.

When I run Oxidized, it runs and grabs configs, the WebUI for Oxidized is accessible. LibreNMS on the other hand displays “We couldn’t retrieve the device info from Oxidized”

Here’s a screenshot of the Oxidized config file, perhaps I’m overlooking something basic?

Please post your librenms oxidized settings.

Here’s the settings per the External config page.

Also not sure if it matters, but here’s the showconfig for oxidized

run: curl http://127.0.0.1/node/show/DEVICE_HOSTNAME?format=json and pastebin the results.

Here is the pastebin results of the curl https://pastebin.com/Wf2DTuMm

I was expecting you to replace DEVICE_HOSTNAME with the hostname of a device :slight_smile:

Wow sorry sometimes I’m a twit. If it’s any consolation, using your recommended curl gave me the same message, however if I run curl with the port# included, I get the following: https://pastebin.com/0HpnUwwf

Ah my bad. Yes you needed :8888

Ok so that last one, you’ve used a completely different url - you need to use the exact one you specified in your config. You also need to include ?format=json at the end.

Gah, hope this one is correct :slight_smile: https://pastebin.com/x5RJXL9v

curl http://127.0.0.1:8888/node/show/arealhostnamehere.company.org?format=json

You’re gonna have to forgive me, I promise I’m not normally this dumb! :frowning:
https://pastebin.com/KMD9jQpZ Here’s the output.

@infinite-ideation Please try this patch https://p.libren.ms/view/9d61a231

I apologize for the delay, however am I pulling this wrong? Used curl -o to download the specified patch url from the project directory, getting an error that the patch does not apply.

[[email protected] device]# cd /opt/librenms/
[[email protected] librenms]# git apply 9d61a231
error: patch failed: html/pages/device/showconfig.inc.php:170
error: html/pages/device/showconfig.inc.php: patch does not apply
[[email protected] librenms]#

If you look at the patch, it’s only a small change so maybe just do it manually for now.

Inserted the code at line 170. Omitted lines 1-4 in your patch as I don’t believe those are are required to be added when manually adding the code. Anyways the error message is gone from the librenms config tab for oxidized, however it’s not displaying the configs. I restarted php/nginx to be safe, but the results are the same. Adding a screenshot of the config file for clarity.

You’ve replaced that line rather than adding a new one right?

Yes, deleted the old lines, inserted the provided patch code. I can restore the backup config and try again. I’ll update as I could have accidentally removed something.

update: just restored the backup config, and reapplied the patch, issue is persistent.

I’m confused, is that the file you are showing me or the patch? If it’s the file showconfig.inc.php then you’ve added both the lines. The - means the line should be removed and the + means the line should be added. You actually only need to add the > that you see on that line so revert the commit and add just that manually.

Reverted, made the correct advised change. Oxidized tab still loads blank - unless again I’ve incorrectly added something?

What do you actually see on the web page?