Oxidized integration failure after HTTPS setup

Greetings All,

To preface I am by no means an expert in Linux, I know enough to get around and get myself in trouble. That being said…

I had a LibreNMS solution with oxidized. Everything was working fine, but decided that running with HTTP was no longer acceptable. I set up a self-signed certificate and was able to get the LibreNMS site working just fine, until a few days later I realized that I didn’t check any device configurations. I am greeted with the “We couldn’t retrieve the device information from Oxidized”.

I checked my Oxidized Source Settings:

source:
default: http
debug: false
http:
scheme: https
secure: false
url: https:///api/v0/oxidized
map:
name: hostname
model: os
group: group
headers:
X-Auth-Token:

(Note The indents are also correct, but not displaying properly on message)

If I curl my URL with the token, I get a listing of all hostnames, etc.

However when I try to query a configuration in Librenms, or get a list of sources in the Overview>Tools>Oxidized menu I get nothing or the error mentioned above.

In addition I see the following error on my CLI running oxidized: “HTTP parse error, malformed request (): #<Puma::HttpParserError: Invalid HTTP format, parsing fails.>”

My ssl cert has the URL the FQDN I am trying to connect to. The API works when using Thunder Client from a different machine, and my Librenms machine (same device as my oxidized device) can curl and see results.

Any thoughts or assistance would be happily accepted.

Thank You and Be Well

We have LibreNMS with CA certificate and Oxidized is able to sync in between.

My config is similar and it just works.

source:
  default: http
  debug: true
  http:
    url: https://hostname.com/api/v0/oxidized
    scheme: https
    secure: false
    map:
            name: hostname
            model: os
            group: group

Did you update the oxidized integration within LibreNMS to use the https url?

I believe so, here is the setting from “Global Settings”: * oxidized.url https://librenms.<domain>.com:8888

What’s the full curl command you’ve tried that works?