Oxidized (only) working issues (HP Procurve)

Hi there’,

I’m using a solo install of oxidized in a first attempt to make it work, understand it and the using it linked with LibreNMS.

But after passed several wrongs configurations issues i’m now block at the situation where oxidized connect to my switches (HP Procurve 2810-24G, another 2510G-48 and finaly a FS.com S3900-24TS4 (acting as a cisco but anyway i’ll try to make it work later)).

See the log about the thing : https://gist.github.com/XaaT/35f3250e3283c617e8f990cffa2609a4

I’m actually only tring on the 2810-24G (same errors with others switches so i’ll aim to make one work and i’ll see after what to do).
So config is simple, one switch, one git repo (file output is not working).

The config is here : <<>>
This is a new box just setup for the test (ubuntu 18.04), gem install, with full access (protocol/ports) throuh our firewall to the management network.
I’ve tried before on a debian 9.6 (gem install), this is the “old” config : <<link in future post as a noob i can’t post more than 2 links…>>

The telnet logs shows good connection on the switch and shows the hostname and prompt #

Tries are set at 3, after one or 2 tries i got “Sorry, the maximum number of telnet sessions are active. Try again later.”
Oxidized doesn’t seems to close to connction or get a connection error. Don’t know why.

Can you help with that ?



Config is here : https://gist.github.com/XaaT/dcd6e0d6c3999a9743401a3daa545a3b
Old config is here : https://gist.github.com/XaaT/6357f134df56d10181372d4e5525bd28

(see the first post for <<>>)

Bump !

I’ve tried a new setup (last docker image) with a switch directly connected, no routing.
Same thing. :frowning:

I think it’s the oxidized device connection log that you need rather than the oxidized process log…

Example I have these:

-rw-r–r-- 1 oxidized 0 May 24 08:11
-rw-r–r-- 1 oxidized 76 May 24 08:11
-rw-r–r-- 1 oxidized 6.1K May 24 08:27
-rw-r–r-- 1 oxidized 1.5K May 24 08:26
-rw-r–r-- 1 oxidized 6.1K May 24 08:22
-rw-r–r-- 1 oxidized 1.5K May 24 08:22

33.11 is a failure - it’s also a Procurve…

I said :

The telnet logs shows good connection on the switch and shows the hostname and prompt #
The connection log

It’s working well with SSH input method, i think the problem is located within telnet.rb
Don’t think this is a setup configuration issue or network issue related to my equipment or routing (i’ve tried another setup)

Did you try with known working versions of oxidized? looks like a known issue

Try keyboard-interactive only and up your timeout you only have it set to 20.

Probably resolvable with a tweaked model file.

The problem was also on the FS.com switch (cisco like), i switch (uhuh) from telnet to ssh on all devices, so… (and it’s working)

How long does it take for a show running-config ? Its possible if the config takes more than 20 seconds to pull then it retries in a loop , try change the timeout to 120 as a test

In telnet ? No incoming data so it’ll trigger the timeout.
In SSH ? Few seconds

For now i’m looking into git sync that’s commit and merge while deleting (deleting few commits) configurations => 5 confs / 25 saved… But it’s another issue