Oxidized-where is the config file? Where is OXIDIZED_HOME set?

Edit: OK, Per the rules regarding more than two links, I tried to morph the links so they didn’t look like links. Sorry if that renders this unreadable.

Installing librenms primarily for oxidized. As I get time I’ll implement the other functionality.

I installed a prefabbed librenms vm based on centos7 on vmware. The centos boots. I’ve changed the passwords. I can connect to the librenms webpage.

I’m having trouble with finding out what I should be using ‘oxidized’ instructions for and what oxidized stuff has been librenms-ized.

For this specific question:

  1. where is the oxidized config file I’m supposed to be working with?
  2. Has it already been created somewhere? or do I need to do it?
  3. If I need to do it, what user do I do it as? user oxidized? or user librenms?
    3 Is OXIDIZED_HOME pre-set in the centos vm? if so, where is it actually set?

What follows below is meant to demonstrate that I have actually tried to follow the directions and searched the docs first, as well as trying to determine the answer myself.

Many thanks in advance.



says “First you will need to install Oxidized following their documentation.”

Um, ok. Isn’t it already baked into the prefabbed vm though? find /opt/librenms -iname oxidized* looks like it is. Including the gem stuff. But ok…


Under Installation: CentOS, the various yum install’s and gem install’s all come back and say all that stuff’s already there.

Moving on.

Now I’m at ytti/oxidized#configuration

useradd oxidized.   

There’s already one in the centos vm. And a group oxidized as well.

Next it talks about initializing a default configuration. Has this been done also? if it has, I don’t want to mess it up.

It also says:

It is recommended not to run Oxidized as root.

Which is cool, I’m definitely on board with that, but…

To initialize a default configuration in your home directory ~/.config/oxidized/config, simply run oxidized once.

Has this already been done in the prefabbed centos vm? If so, where is it? Nor can I locate any reference to OXIDIZED_HOME, either as user root, librenms or oxidized.

If I try to ‘run oxidized once’ as user ‘oxidized’ (which, while not stated specifically in the oxidized documentation, seems like that’s what it wants) it fails.

oxidized@librenms01 ~]$ which oxidized
/usr/bin/which: no oxidized in...

Examining the oxidized executable for permissions:

oxidized@librenms01 ~]$ ls -la /opt/librenms/bin/oxidized
-rwxr-xr-x. 1 librenms librenms 497 Apr 27 2020 /opt/librenms/bin/oxidized

So do I ‘run oxidized once’ as oxidized, as per the oxidized documentation? or run it as librenms just because I’m supposed to instinctively know that?

And that’s as far as I’ve gotten.

This topic was automatically closed 186 days after the last reply. New replies are no longer allowed.