Since upgrading to 24.6.0 (came out today) sometimes the page fails to load ( Whoops, looks like something went wrong. Check your librenms.log.) but a quick refresh resolves it. I’ve not had any issues such as this until I upgraded to 24.6.0. I’m running LibreNMS in a FreeBSD jail.
Log shows the below error when the page fails to load:
Directory /tmp//HTML not writable. {“view”:{“view”:“/usr/local/www/nginx/resources/views/components/toast.blade.php”,“data”:},“userId”:2,“exception”:“[object] (Spatie\LaravelIgnition\Exceptions\ViewException(code: 0): Directory /tmp//HTML not writable. at /usr/local/www/nginx/vendor/ezyang/htmlpurifier/library/HTMLPurifier/DefinitionCache/Serializer.php:295)
[previous exception] [object] (ErrorException(code: 0): Directory /tmp//HTML not writable. at /usr/local/www/nginx/vendor/ezyang/htmlpurifier/library/HTMLPurifier/DefinitionCache/Serializer.php:295)”}
$ ./validate.php
| Component | Version |
|---|---|
| LibreNMS | 24.6.0 (2024-06-17T02:23:37+10:00) |
| DB Schema | 2024_04_29_183605_custom_maps_drop_background_suffix_and_background_version (294) |
| PHP | 8.2.20 |
| Python | 3.9.19 |
| Database | MariaDB 10.6.18-MariaDB |
| RRDTool | 1.8.0 |
| SNMP | 5.9.4.pre2 |
| =========================================== |
[OK] Composer Version: 2.7.7
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK] Database and column collations are correct
[OK] Database schema correct
[OK] MySQL and PHP time match
[OK] Distributed Polling setting is enabled globally
[OK] Connected to rrdcached
[OK] Active pollers found
[OK] Dispatcher Service is enabled
[OK] Locks are functional
[OK] No active python wrapper pollers found
[OK] Redis is functional
[INFO] fping FAILURES can be ignored if running LibreNMS in a jail without ::1. You may want to test it manually: fping ::1
[FAIL] /usr/local/sbin/fping6 could not be executed. /usr/local/sbin/fping6 must have CAP_NET_RAW capability (getcap) or suid. Selinux exclusions may be required.
(/usr/local/sbin/fping6: can’t create socket (must run as root?))
[OK] rrdtool version ok
[OK] Connected to rrdcached
[WARN] Log rotation not enabled, could cause disk space issues
[FIX]:
sudo cp /usr/local/www/nginx/misc/librenms.logrotate /etc/logrotate.d/librenms
[WARN] Your local git contains modified files, this could prevent automatic updates.
[FIX]:
You can fix this with ./scripts/github-remove
Modified Files:
dist/librenms.cron