Palo Alto PPPoE port not showing traffic in graph

Good evening,

We’ve added a firewall Palo Alto in our network and we would like to monitor a specific port PPPoE connected to our provider in order to get traffic’s graphs. At physical level unfortunately we can’t see nothing, is there a way to modify poller settings and set PPPoE transport on this port?

Thanks in advance, below you can find my ./validate.php and output of ./poller.php -h -m ports -d

(specific port is ethernet1/1 = link to BitService)

[[email protected] librenms]# ./validate.php

Component Version
LibreNMS 1.43-85-g8f89cd5
DB Schema 267
PHP 7.2.7
MySQL 5.5.60-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Composer Version: 1.7.2
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

Poller output: https://p.libren.ms/view/c020e86f

PPPoE is an ignored interface by default.

You can enable it with $config['good_if'][] = 'pppoe-';

Not sure if thats is what you want…

Hi Doc, thanks for your fast response.

I’ve enabled this settings on my config.php during troubleshooting, but after repeating the polling the issue still remains. Do i have to specify something else in the command line or repeat discovery?

Thanks again.

For what it is worth, in my config.php, I did a

unset($config['bad_if']);
unset($config['bad_iftype']);

After that, I then copied all the bad_if and bad_iftype section from includes/defaults.inc.php, changing and omitting what I needed in config.php, putting it all after those two lines. (Of course, do not change includes/defaults.inc.php) I hope that is helpful.

Run ./discovery.php -h host and check if interface is recognized and created. It may need 5-10 min to start graphing.

Dude, you did the hardest way.

Just setting good_if/good_iftype in config.php is enough. config.php is on top of defaults

So, there are config options not in the defaults.inc.php… :face_with_raised_eyebrow: Lesson learned, thanks Doc.

$ grep good_if functions.php 
 * Settings: empty_ifdescr, good_if, bad_if, bad_if_regexp, bad_ifname_regexp, bad_ifalias_regexp, bad_iftype
    if (str_i_contains($ifDescr, Config::getOsSetting($device['os'], 'good_if'))) {

Hi Doc,

Hope your day is going well. Unfortunately i’ve not specified that this interface is already created on my Libre.
This is output of my ./discovery -h host : Discovery Poll - LibreNMS

Do I have to delete device first and then try to re-discover?

This is output of my actual situation on Web GUI (port ethernet 1/1):

Thanks for your support.

Is the pppoe connection up and running when you did the discovery?

If yes, seems like PaloAlto is not reporting the pppoe interfaces.

Also, does that pppoe connection the only one? Is using an specific interface only for that?

That interface is the only one PPPoE, is up and i can see virtual traffic inside through PaloAlto CLI.

It should be a problem of PaloAlto then, i’ll try to open a support request and let you know.

Thanks.

What I mean is: If the PPPoE connection is using a dedicated physical interface, isnt enough monitoring that interface?

Hi Doc,

after opening a case to PaloAlto support, that was the answer:

Issue Report : " PPPOE interface on P.A firewall was unable to monitor in SNMP Server ".

Troubleshooting Done :-

>> As you have informed that SNMP server was able to monitor the traffic from Palo Alto firewall with all Ethernet interface, except Ethernet 1/1.
>> Checked Ethernet interface 1/1 found that interface was configured to PPPOE connection.
>> Referred the technical document from the url :- https://live.paloaltonetworks.com/t5/Management-Articles/PPPoE-Ignores-Physical-Interface-Link-Status/ta-p/55311 and informed the customer as the Ethernet interface 1/1 was configured to PPPOE connection it ignores the physical link status on the firewall so that was the reason the SNMP server was unable to monitor the traffic for the firewall Ethernet interface 1/1.

i’ve opened a feature request for this issue, hope they will fix it soon.

Thank again for your support.