Permissions Error with Graph / Manual Ports Widget

Goal: I’m trying to get my test account with normal level access to view a widget configured as [Graph > Graph Type: Manual Ports ]

I’m getting an error on my test account when trying to view any Widget configured as [Graph > Graph Type: Manual Port ] even if I’ve already granted my test account access to the whole device itself.

If I create a Widget by using [Graph > Graph Type: port_bits ] I am able to successfully view the Widget on my test account; The problem with using port_bits is that it only displays 1 port on the graph, whereas using “Manual Ports” allows me to specify several ports in 1 graph.

I’ve verified that I granted my test account access to the device I’m trying to view

All accounts with admin level access have no problem viewing any widgets I create

Additionally, if I use Manual Ports and only specify 1 port I get the same error, however, if I create port_bits widget and specify the same port it works. Both these ports are on the same device and the only difference is the Graph Type (i.e Manual Ports vs. port_bits )

Is there something I am missing? I’ve already tried this with multiple devices.