PHP 8.3 issues after update on Raspian server

So the other day I ran a full update on Raspian running Librenms, and now I’m running into this message when I visit the before working Librenms page:

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 8.1.0".
And so far I have only tried to run ./daily.sh to hopefully remedy this, but that did not help.
php -v

PHP 8.3.2-1+0~20240120.16+debian11~1.gbpb43448 (cli) (built: Jan 20 2024 14:17:59) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.3.2, Copyright (c) Zend Technologies
with Zend OPcache v8.3.2-1+0~20240120.16+debian11~1.gbpb43448, Copyright (c), by Zend Technologies

./scripts/composer_wrapper.php install --no-dev

LibreNMS\ComposerHelper::preInstall
Installing dependencies from lock file
Verifying lock file contents can be installed on current platform.
Nothing to install, update or remove
Package influxdb/influxdb-php is abandoned, you should avoid using it. No replacement was suggested.
Package nunomaduro/larastan is abandoned, you should avoid using it. Use larastan/larastan instead.
Generating optimized autoload files
Illuminate\Foundation\ComposerScripts::postAutoloadDump
@php artisan package:discover --ansi

   INFO  Discovering packages.  

  laravel-notification-channels/webpush ................................. DONE
  laravel/socialite ..................................................... DONE
  laravel/tinker ........................................................ DONE
  laravel/ui ............................................................ DONE
  librenms/laravel-vue-i18n-generator ................................... DONE
  mews/purifier ......................................................... DONE
  nesbot/carbon ......................................................... DONE
  nunomaduro/termwind ................................................... DONE
  php-flasher/flasher-laravel ........................................... DONE
  silber/bouncer ........................................................ DONE
  spatie/laravel-ignition ............................................... DONE
  tightenco/ziggy ....................................................... DONE

75 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
LibreNMS\ComposerHelper::postInstall
Illuminate\Foundation\ComposerScripts::postInstall
@php artisan vue-i18n:generate --multi-locales --format=umd
@php artisan view:cache

   INFO  Blade templates cached successfully.  

@php artisan optimize

   INFO  Caching the framework bootstrap files.  

  config ........................................................... 88ms DONE
  routes .......................................................... 231ms DONE

@php artisan config:clear

   INFO  Configuration cache cleared successfully.  

scripts/dynamic_check_requirements.py || pip3 install --user -r requirements.txt || :

So what can I do to fix this issue?

Tried downgrading PHP? I’m running 8.2.14 which is working fine due to a similar issue with the latest version of PHP.

Yeah, I could probably try that of course. But I fear that I will wreck everything.

This would be related i’d say, which will be released in the next patch regarding 8.3

and this

ah, thats great news then! So then I just wait for the release.

Thanks a lot!

I’m already running php 8.3.1 with no errors

I had to change some php config from php 8.2 to make 8.3 work.

PHP 8.1.0 and above is supported.

Care to share what config you did alter?

I went through the setup

Checking for any references to php 8.2 and changed them to 8.3.

I think it was only the php and webserver config that changed.