PHP Fatal error: Uncaught ReflectionException

Encoutered error on

$ ./
Updating to latest codebase OK
Updating Composer packages OK
Updating SQL-Schema FAIL
PHP Fatal error: Uncaught ReflectionException: Class App\Exceptions\Handler does not exist in /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php:790
Stack trace:
#0 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php(790): ReflectionClass->__construct(‘App\Exceptions\…’)
#1 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php(667): Illuminate\Container\Container->build(‘App\Exceptions\…’)
#2 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php(265): Illuminate\Container\Container->resolve(‘App\Exceptions\…’, Array, false)
#3 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php(787): Illuminate\Container\Container->Illuminate\Container{closure}(Object(App\Application), Array)
#4 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php(667): Illuminate\Container\Container->build(Object(Closure))
#5 /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Contain in /opt/librenms/vendor/laravel/framework/src/Illuminate/Container/Container.php on line 790
Updating submodules OK
Cleaning up DB OK
Fetching notifications OK
Caching PeeringDB data OK

Page is not working now. Need help Thanks in advance.

That file definitely should exist. What does ./validate.php show?

This is the result of my ./validate.php

but composer is already installed

I am getting all of the same errors. There was another thread that said to try running the ./, which I did, but still getting errors. I just get a blank screen when trying to load up the page.

It uses ./scripts/composer_wrapper.php ( think the system version you have is too old)

If you can download composer.phar and put it in /opt/librenms to make it work. The script tries to download it, but something on your server must stop the download.

Same error occurs after downloading composer.phar

Try reinstalling the php dependencies:
rm -rf /opt/librenms/vendor
./scripts/composer_wrapper.php install --no-deps

Ok, I tested adding garbage to my /opt/librenms/vendor/composer/installed.json file and it had the same result. Reinstalling the vendor directory as I described above should fix you.

I wonder how it got corrupted in the first place…

Thanks a lot @murrant issue is now fixed