Ping intervals

Hi Guys,

I would like to understand, by adding new device , by default it check SNMP and ICMP availability
SNMP availability is checked by interval you set in the cron job file
what about ICMP? where I can see the intervals?
Can I create alert notification based on ICMP only if device is down?

Here are the options for ICMP (Fping) used for ICMP checks

You can create alert rule for device down from ICMP it would look something like this

CRITICAL Device Down Alert: %macros.device_down = “1” && %devices.status_reason = “icmp”

It’s the same as snmp. ICMP checks are only done at poll time.

Use services if you want something more.

So if I change SNMP cron from 5m to 1m, the icmp will be automatically changed to 1minute?

There is no cron for “SNMP” per say… The poller does all of that, if you want 1 min polling you will need to do the following.

Hi Kelvin,

Do I need also to do this part for 1 min pulling ?

Converting existing RRD files
We provide a basic script to convert the default rrd files we generate to utilise your configured step and heartbeat values. Please do ensure that you backup your RRD files before running this just in case. The script runs on a per device basis or all devices at once.

The rrd files must be accessible from the server you run this script from.

This will provide the help information. To run it for localhost just run:

./scripts/rrdstep.php -h localhost


afik yes

so in the first step it says to change the poller-wrapper cron time
so now it’s set to this value in the cron file, if I want one minute I should use */1 * instead of */5 *

*/5 * * * * librenms /opt/librenms/cronic /opt/librenms/ 16

yes, correct.

done , now it says navigate in the gui to /pollers/tab=pollers/ , where I can find it in the gui?
And what value i should put there the same I used in the cron?

type in the url

Got it, this what I get, I can’t change the values, what this step gives me?

you don’t change values there… take note of the values and then go to the next step …

To make the changes, please navigate to /settings/sub=external/ within your WebUI. Select RRDTool Setup and then update the two values for step and heartbeat intervals:

Step is how often you want to insert data, so if you change to 1-minute polling then this should be 60.
Heartbeat is how long to wait for data before registering a null value, i.e 120 seconds.

completed, now the only step is to execute this command?

As long you completed all the steps then Yes run the script

Thanks, works fine

Hey - Awesome I’m glad it worked :smile: