PoE polling on HP Switches

Hey yall – I’m not seeing PoE polling on any have my HP switches
I put $config[‘enable_ports_poe’] = 1 in the config.php but still not seeing anything.

We use two standard mibs for this, POWER-ETHERNET-MIB and CISCO-POWER-ETHERNET-EXT-MIB. If this device doesn’t utilise either then it will need additional code.

Run ./poller.php -h HOSTNAME -d -r -f -m ports to get some debug info, look for pethPsePortEntry and cpeExtPsePortEntry, I expect you will see an error from snmp

https://p.libren.ms/view/31dc96e4 here you go. Let me know what else you need

I think HP uses the www.oidview.com/mibs/11/HP-ICF-POE-MIB.html

Discussed in https://github.com/librenms/librenms/issues/6736 - HP switches should be fairly straightforward according to the SNMP::Info patch, the last value is the ifIndex.

That HP MIB is for extra information on top of POWER-ETHERNET-MIB. Enterasys have a similar one for extra info, ENTERASYS-POWER-ETHERNET-EXT-MIB

Can you please share the output of:
snmpbulkwalk -OUneb -v2c -c COMMUNITY HOSTNAME .

I got the output but it’s too big to upload to Pastebin and p.librenms… do know where I can upload it to?


What size is it?

its 4,027 KB

Odd, should work on our site but try that one above.

I’m getting errors when snmpbulkwalk -OUneb -v2c -c COMMUNITY HOSTNAME . | ./pbin.sh

A PHP Error was encountered

Severity: Warning

Message: Error while sending QUERY packet. PID=13406

Filename: mysqli/mysqli_driver.php

Line Number: 306

Upload it to another one for now

It won’t take it either … IDK man what I’m doing wrong here :frowning:

Hey @Kevin_Krumm,

Did you find the solution to this?
I’m using all Aruba/HPE switches and need to monitor the Detection Status of all my ports.
The other day I had 4 ports going bad on the PoE (ports b9 to b12) on one of my modules and I didn’t notice until a colleague told me that 4 ports were with steady amber lights.

I would like to know how are you monitoring your aruba gear.


Is there someone who can help me on this?
Or should I create a new thread.

Hi @hrv231
Basically, if the POE is not showing, it means that LibreNMS does not have code to handle it.

Two options :

  • You can write the code, test it in your environnement, open a pull request, let the admins review it and merge it to LibreNMS
  • Open an issue (if not opened already) here (https://github.com/librenms/librenms/issues) and provide the required data. And wait for somebody else to do it. But unfortunately the list of opened issue is very big, and we lack contributers on those issues, meaning it may take a lot of time …

Then this is bad.
If things are taking forever and there are so many issues, then what’s going to be the future of LibreNMS ?
I’m having also problems with Device Groups and using regex, I ran regex properly but still some devices do not show on the groups.
I feel like something is wrong with that code as well.

Hi @hrv231
The future of LibreNMS is on all users/contributors hands. We are improving LibreNMS on our spare time. So a few hints:

  • We lack contributors
  • We lack free time

You can indeed code the POE support yourself as already suggested, that’s how LibreNMS is growing.
You can troubleshoot any REGEX issue in the groups by providing a step by step path to reproduce it, that will make it easier for contributors to solve it. Or may be we’ll help you identify a mistake in the regexp.

If you cannot help/contribute, then unfortunately you have to wait for somebody else to do it, and my point was to warn you that it’ll take time, considering the current backlog.


1 Like