Poller-wrapper.py wont connect to db after updating to 1.64

====================================

Component Version
LibreNMS 1.64.1
DB Schema 2020_04_06_001048_the_great_index_rename (165)
PHP 7.4.6
Python 3.6.8
MySQL 5.5.65-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2
====================================

[OK] Composer Version: 1.10.6
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database schema correct

After upgrading to the latest release with ./daily.sh im getting “Devices unpolled” error. Initially i thought it the poller wil cycle itself, then i rebooted to no avail. If i run poller.php it works, but when i do poller-wrapper.py im getting could not connect.
[[email protected] ~]$ ./poller-wrapper.py
ERROR: Could not connect to MySQL database!
ERROR: (2003, “Can’t connect to MySQL server on ‘localhost’ ([Errno 111] Connection
refused)”)
I dont know if this is relevant or related but, im also getting phyton warning in the WebUI
Warning: Could not check Python dependencies because this script is not running as librenms

this is Centos7 vm image i downloaded and imported in our proxmox.

Please let me know if you need anything else in order to resolve this issue
Thanks,
Mladen

I am seeing the same issue.

Few different fixes:

  1. Set db_socket: Look here from another user Poller Not Running from Cron

  2. Try installing mysqlclient with pip3 install mysqlclient. If after installing it becomes with Access Denied, change your mysql user host to 127.0.0.1 instead localhost.

The first one will work for sure, the second one not sure if Im missing a step.

Thank you so much the db_socket worked from the get go i didnt even tried to test the second solution.

Thanks!
Mladen