Polling Bug?!

Hi guys,
I’ve update my librenms to latest stable version.
Begin to update it, everyall work…but after update i have some problem with poller…it try to poll my device (480 device) …for some minutes it polling them, until 320…after this turn back to 480 alert…what is possible cause? i try to poll with normal poller not with new poller module.

I have had a similar issue.

Figure out your CPU/CPU Core Count and change your CPU Threads, and "tail -f " the librenms.log file. Then go into all your devices and disable/turn off any module that is actually not pulling any data. Start out with the ones that take the longest to poll and disable any modules that are not pulling any data and see what happens.

The librenms.log file will let you know if your CPU Threads are not enough. If it is a VM, you might have to add more CPU/Cores.

About 2 months ago I updated my really old libre install to the latest stable version and all the modules were turned on for all my devices.

Prior to updating, I kept getting false positive alerts at random intervals that would happen every few days, especially for Eltek Rectifiers that the Elteks were down, even though they were just fine. After the update, I would get false positives almost daily and something the alerts would be for the same device even though everything was fine with the Elteks.

Once I started disabling/turning off unneeded modules on a couple of devices, I started noticing a huge difference.

which modules do you have keep on?
For better efficiency?

You can use the ./poller.php -h command to determine what will work best for you.

Basically, any module that doesn’t return any data you can turn off.

well, i turn buck after various test…
With new librenms it’s aviable the Dispatcher Service as polling,discovery and alert…ok it’s fine…but snmp often go down-up in randoom intervall…many users say that’s probably poller missconfiguration…

in my VM machine i have
8 Cpu Core - 2 Socket (4 Core x Socket)
4 GB RAM
280 GB HHD.

i have 780 devices in my network.
i create also various poller group…but after i had set in apposite menù (Poller Settings) → Assigned Groups, the groups expires from it.

If you don’t have more than one poller machine then don’t use poller groups.

If you want to change Poller settings in the UI first stop the poller, change the GUI, start the poller.

I would reduce discovery workers to say 2 or 4 and see if that smooths out your CPU usage.

Perhaps some more RAM ? Do you monitor the CPU/RAM on the host?

i think to know where is the problem…when disable fast ping, everyall work fine…how can i set fast ping for avoid continually snmp up/down?