Port missing from device / excesive snmp querie info

Hi guys, Im trying to find out why there is a vlan port missing on my router device port list.
I have other similar ports configured at same device with no problem on librenms.

Capture tools (snmp) lead me to following log message:

[2019-10-23 13:07:05] production.ERROR: The process “‘/usr/bin/snmpbulkwalk’ ‘-v3’ ‘-l’ ‘noAuthNoPriv’ ‘-n’ “” ‘-u’ ‘version3’ ‘-OUneb’ ‘-M’ ‘/opt/librenms/mibs:/opt/librenms/mibs/mikrotik’ ‘-t’ ‘120’ ‘udp:’ ‘.’” exceeded the timeout of 60 seconds. {“userId”:1,“exception”:"[object] (Symfony\Component\Process\Exception\ProcessTimedOutException(code: 0): The process "‘/usr/bin/snmpbulkwalk’ ‘-v3’ ‘-l’ ‘noAuthNoPriv’ ‘-n’ "" ‘-u’ ‘version3’ ‘-OUneb’ ‘-M’ ‘/opt/librenms/mibs:/opt/librenms/mibs/mikrotik’ ‘-t’ ‘120’ ‘udp:’ ‘.’" exceeded the timeout of 60 seconds. at /opt/librenms/vendor/symfony/process/Process.php:1237)

I already set 120 sec as you can see on -t flag , but error still there.
Also executed the command on server cli:

snmpbulkwalk -v3 -l noAuthNoPriv -u version3 udp:

And goy an excesive snmp info … after 2 mins I had to ctrl-c to exit.

Is there something more I can tweak ?
Is it normal , that librenms request too much info from device ?
Can I manually set what ports I need ?
Other Idea to solve this ?


Hi guys , still trying to solve this.
Im afraid , that if can not add this port should go back to my old cacti platform.

After performing ./daily.sh ./validate.php and ./discover.php there are no error / warning messages.
Then , looking at capture/discover tool output founded this sentece:

ignored by ifDescr: TO_PEPRAS (matched: ras)
Using ifDescr as ifAlias

Which is the missing vlan name.
So , I had to add:
$config[‘good_if’] = ‘ras’;
to config.php … this make the trick,
Hope to help someone.