Port Settings

Hi all,

under port setting it states the following " n.b For the first time, please click any button twice"
as I have some issues with my ports please see below

(and no, clicking any button twice does not work!)

This issue is part of something that is wrong with the way Libre is monitoring the ports as it is making duplicates every time a port goes down and back up again at the moment one of my hosts has made 5269 RRD files

Thanks in advance.


By default, librenms uses ifIndex as Port Association Mode.

If the ifindex of an interface in your device changes everytime it goes down and up again, you should try to configure your switch to have persistent indexes OR just change the port assoc mode to ifName, ifDescr or ifAlias.

I have changed it to Ifname but yet it still does this. I have found this.
Which will purge it after 10 days ( $config['port_fdb_purge'] = 10;)
but I’m not sure if this purges everything.

anyway I found this
the deleted ports keep their RRD file which needs to be deleted

Cleanup Options

As the number of devices starts to grow in your LibreNMS install, so will things such as the RRD files, MySQL database containing eventlogs, Syslogs and performance data etc. Your LibreNMS install could become quite large so it becomes necessary to clean up those entries. With Cleanup Options, you can keep in crontrol.

These options rely on daily.sh running from cron as per the installation instructions.

Cleanup Options are set in config.php

$config['syslog_purge']                                   = 30;
$config['eventlog_purge']                                 = 30;
$config['authlog_purge']                                  = 30;
$config['perf_times_purge']                               = 30;
$config['device_perf_purge']                              = 7;
$config['alert_log_purge']                                = 365;
$config['port_fdb_purge']                                 = 10;
$config['rrd_purge']                                      = 90;// Not set by default

These options will ensure data within LibreNMS over X days old is automatically purged. You can alter these individually, values are in days.

NOTE: Please be aware that $config[‘rrd_purge’] is NOT set by default. This option will remove any rrd files that have not been updated for the set amount of days automatically - only enable this if you are comfortable with that happening. (all active rrd files are updated every polling period)
Ports Purge

Over time as you add devices some interfaces will need to be purged as they are set to be ignored or bad interfaces or marked as deleted.

You can purge all deleted ports from the WebUI (see below) or by setting $config[‘ports_purge’] = true; in config.php

In the Web UI Under the Ports Tab in the Nav Bar, Click on “Deleted” then click on “Purge all deleted”. This will purge all the ports.

So you did go to device -> Edit -> SNMP and changed from ifIndex to another one and it keeps adding new ports?

I changed it to Ifname and from yesterday it added 4 more