Ports not being ignored and Disabled


My system:

Component Version
LibreNMS 1.33-298-gda54444
DB Schema 227
PHP 7.1.11
MySQL 5.1.73
RRDTool 1.3.8


I have a device, Cisco 4507 in vss mode where Librenms has detected “Uncontrolled” and “Controlled” ports along the regular ports. The Regular ports are working just fine.

In the settings of this device I have set all the ports that are “Uncontrolled” and “Controlled” to be disable and ignore.

The “Uncontrolled” and “Controlled” ports that are detected as down are still showing up in my notifications.

I am trying get these ports not to show up in my notifications. What am i doing wrong, if anything?


You need to add %macros.port = 1 to your rules to have them take that setting into account.

I have this %macros.port_down = “1” in my Port status up/down rule.

Add %macros.port = “1” to it or replace?

Thanks for your quick response!


When you set the ignore and disable the port are you double clicking the save button?

Yes, I double click the save.


If the ports have a description or name maybe you could exclude them from the alert rule or use alert rule mapping.


I just deleted the rule from “alert rules” and then re-added it back in.

That did the trick.

I did that with another rule a while back and that fixed the issue.

Thanks for insight!


1 Like