Ports Page


For some reason the “All Ports” page stopped working today, I’m not sure what happened I haven’t made any changes.

Overview>Ports>All Ports

I restarted httpd and checked permissions and also ran ./validate.php and don’t see any errors.

any help would be appreciated.

thank you

Not sure what your issue may be.

Are you familiar with Chrome or Firefox developer tools?
For Chrome:

  1. Hit F12
  2. Select the network tab
  3. Reload the All ports page.
  4. Find ajax_table.php in the list
  5. Select the Response tab.
  6. Pastebin the entire contents of that tab.

this all i see. I’m not sure how to get the ajax_table.php

You have an error in the php of that page somehow. Can you post the results of your validate.php here?


Component Version
LibreNMS d8fcdc9ae3cf7a5cdafca865c9ada7551f85a03f
DB Schema 185
PHP 7.0.17
MySQL 5.5.52-MariaDB
RRDTool 1.4.8


[WARN] Your install is out of date, last update: Tue, 18 Apr 2017 22:42:56 +0000
[OK] Database connection successful
[OK] Database schema correct
[FAIL] You have no timezone set for php. [FIX] http://php.net/manual/en/datetime.configuration.php#ini.date.timezone

Could the time zone cause the issue? I know i set it.

It is best to get fixed. There may be separate php.ini files for cli, php-fpm, and apache. Make sure to get it set in all of them.

Try adding debug to the end of the ports url and see if that gives any output

OK will do fix the timezone.

Here is a screen shot with debug

Could the rrd cahce cause a problem? I know that was enabled the other day followed the directions


Possibly, if there was some kind of error in the configuration. Try commenting out the changes you made in config.php

OK, i fixed the timezone. I commented out the RRD cache to see if that would fix the all ports page, still no go.

anything else i could check? thank you for your help.

Looks like got it fixed. One of the user logins on the web gui had crashed php and was trying allcat more ram. kicked all users out of the GUI and rebooted seem to fix the issue.

IS there any way to set WebUI user timeout?

$config['auth_remember'] = 1; - Value is in days

thank you.