Pre 1.44 checks - php-mysqlnd

after reading the pre-checks I realized that I am still on php7.0-mysql and wanted to replace it.
I am still on Ubuntu 16 since running upgrade to 18 broke like everything and I didn’t bother debugging it since there was no need.

I tried uninstalling php7.0-mysql and then installing mysqlnd but it always automatically selects mysql and I was not able to work around it.

apt-get install php-mysqlnd
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘php7.0-mysql’ instead of ‘php-mysqlnd’
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 124 kB of archives.
After this operation, 485 kB of additional disk space will be used.
Get:1 xenial-updates/main amd64 php7.0-mysql amd64 7.0.32-0ubuntu0.16.04.1 [124 kB]
Fetched 124 kB in 0s (470 kB/s)
Selecting previously unselected package php7.0-mysql.
(Reading database … 98549 files and directories currently installed.)
Preparing to unpack …/php7.0-mysql_7.0.32-0ubuntu0.16.04.1_amd64.deb …
Unpacking php7.0-mysql (7.0.32-0ubuntu0.16.04.1) …
Processing triggers for php7.0-fpm (7.0.32-0ubuntu0.16.04.1) …
Setting up php7.0-mysql (7.0.32-0ubuntu0.16.04.1) …
Processing triggers for php7.0-fpm (7.0.32-0ubuntu0.16.04.1) …

I also tried enabling it with " phpenmod mysqlnd" but I see no effect.

Any pointers on how to fix this? Been searching up and down but my google-foo is failing


I’m using debian stretch and am usingf both mysqlnd and memcached but GUI validate.php fails on both of them. CLI validate.php passes fine…

There are some tests for mysqlnd at:

You may already be using mysqlnd, it is included in php7.0-mysql meta package.

EDIT: This caused me to start thinking (never a good thing) and I realised that I was still using libapache2-mod-php5 so I’ve installed libapache2-mod-php7.0 and this sorted the validation issue.

1 Like

Ah thanks a lot, used emotality’s code and that seems to confirm your assumption is correct .

  • MySQL is not installed.
    - MySQLi is installed.
    - MySQLnd driver is being used.
    - PDO MySQLnd is enabled.

Not sure why identifying that has been made so cryptic but most ppl probably won’t bother to check if its a drop in replacement…