Problem to add new OS and polling

Hi everyone,

I try since a week to add a new OS support in LibreNMS for LoadBalancer Alteon Radware.
Indeed, I can add the Alteon in LibreNMS but they are class as Generic Device and poll none information.
I try to follow the tutorial here : but it still not working.
I create a file alteon.yaml in /include/definition and an other file in /polling/os but all the alteon are still as generic devices.
I rediscover the device with discover.php et poller.php but no information are poll.

Thanks for your help.

You’ll need to post the code :slight_smile:

Yes sorry I forgot.
here the 2 file alteon.yaml and


os: alteon
text: 'Alteon Radware’
type: loadbalancer
icon: alteon
- { graph : device_bits, text: ‘Device Traffic’ }
- { graph : device_processor, text: ‘CPU Usage’ }
- { graph : device_mempool, text: ‘Memory Usage’ }
- sysObjectId: enterprises.1872.

<?php $version = preg_replace('/[\r\n"]+/', ' ', snmp_get($device, "productVersion.0", "-OQv", "ALTEON-PRIVATE-MIBS")); $hardware = "Alteon " . preg_replace('/[\r\n"]+/', ' ', snmp_get($device, "productName.0", "-OQv", "ALTEON-PRIVATE-MIBS")); ?>

Thanks for you responce.

sysObjectId only accepts all numeric oids

try sysObjectId: .

Also, you can probably make that more generic by removing sections from the end. Based on how Alteon defines their product sysObjectIDs

Thanks for your responce but I try with this sysObjectID but it still not working and sitll reconise all alteon device as Generic Device.
Of course, I rediscover the device after change the sysobjectId.

Post the output of:

./discovery.php -h HOSTNAME -d -m os


I got two devices showing as Generic Devices and it is TP link router and Billion Router, they both got Same Object ID on the portal, can it be?

Support will need to be added for those devices. Please open your own thread.