Problem with email notifications

I’ve been using LibreNMS for a while and it works great. The email notification works fine for the default alert rules. I’ve installed the agent on a couple of hosts and added a custom alert rule (check for a specific process). The alert triggers just fine, but it seems to have a problem with sending an email notification. Are these using different email configurations?

I get alert emails for the default alert rules, but I get a for my custom rule.

Please see attached screenshots.


out of interest try disabling auto tls support.

Unfortunately no difference. It works if the host goes down, but not if the specified process dies. I set up Pushbullet instead and it works great.

I’ve just tested this exact rule and it worked fine for me:

Alert for device localhost - fatcontroller
Severity: critical
Timestamp: 2017-02-07 20:56:06
Unique-ID: 22467
Rule: fatcontroller
  #1: pid => 1;
Alert sent to: NOC <redacted>

You could run the alerts capture for the device you expect to see this for and see what email address would be used.

Also worth noting the match on like uses mysql regex so your rule wouldn’t match unless the process command was exactly what you entered. At most you want @fatcontroller@ (@ is a wildcard for us)

Ok, thanks! I’m going to make some more tests then.

The rule match; it shows up in the web gui and I get Pushbullet notifications. The email notifications work for the host, but not the processes rule.


1 Like

Ok well then the process name must be matching exactly, I was more just giving you an fyi about how it worked :slight_smile: