Problem with last update of Librenms

Help is needed!

All of our Cisco 4506 stopped showing tons of health graphs.
The only graphs left is Overview and Processor.
And on all of our ASR 920’s started new graphs for dBm and temperature…

Anyone else seen this problem?

Best regards,



Please, pbin the output of ./validate.php and one ./discover.php -d -h affectedhost + ./poller.php -d -h affectedhost

When i ran a ./discovery -d -h oneofthehost and forgot the | ./ it rediscovered it and fixed that host.
So i guess i’ll just need to rediscover all 4506’s again.

If that won’t work i’ll pbin them the right way! :slight_smile:
Thanks for the help so far!

Ok, cheered to early.
./discovery.php --os “iosxe” just broked that fixed 4506 again…

So i’ll run those pbins for ya.

The pbin of discovery didn’t go that well tho… :frowning:

Paste endpoint:
name: zeta
private: 1
expire: 0
Error: Missing paste text

I’ll try again…

Ok, I can’t paste in the information in the
But if i choose create encrypted>it works so i guess you can decrypt it at your end?
Anyway here’s a ./poller.php -d -h

The discovery.php -d -h seems to big even for the encrypted way.

But some more info, when i rediscover one of the cisco 4500 it graphs the sensors correct for awhile and then it’s gone again.

Need some tips of what it could be!

No, I cant decode to.

If you run ./ | ./discovery.php....blablabla it should create a link for you to share.

Doesn’t work, the output is to big so the pbin part just returns an error.
So i guess i have to send em some other way or is it something special in those outputs you looking for?
If so i can fix that part.

To be honest, there is no much sense on what it happening to you.

Try with ./discovery.php -d -h host -m sensors first on the 4506 and then on one iosxe.

Lets try to see why discovering iosxe remove health sensors for 4506

I think the sensors just removes itself… not sure how tho.
This morning i ran ./discovery.php -h host and i got the sensor graphs, now they’re gone…

So we can forget the iosxe part because yesterday when i tried discovering all --os iosxe it was just something else running and removing those sensors graphs just like with this hose i tried on today.

Not sure how that is happening tho…

But I ran a ./poller.php -d -h host -m sensors now and here’s the output from that.
And this one is after rediscover the same host.

When i running the discovery with -m sensors and tried to put it into the damn i got this error.
"# A Database Error Occurred

Error Number: 1153

Got a packet bigger than ‘max_allowed_packet’ bytes"
so doesn’t like that data! :frowning:

This is how the graphs becomes after a rediscover…

I’m seeing similar issues affecting devices running IOS, IOS-XE, and NX-OS. All sensors get removed (temp, power, transceiver) and memory and CPU gets removed, too, but not always. Uploaded some outputs:


./discovery.php -d -h affectedhost -m sensors

It looks like the problem started early on January 29 for me when the nightly discovery job ran. The first sensor being deleted, according the Event Log in LibreNMS, is 2019-01-29 00:37:01 (Eastern time). The cronjob to running ‘discovery.php -h all’ began at 00:33:00 that night.

Re-running discovery.php on an affected host makes the sensors come back, for a period of time, and there’s a gap in the graphs but the historical data is still there. The sensors then delete themselves on what seems like a run of discovery.php from a cronjob. I haven’t been able to capture any outputs when that occurs.

Yeah, sounds about right.
And i guess it’s the 33 */6 * * * librenms /opt/librenms/discovery.php -h all >> /dev/null 2>&1
Runs every 6th hour so it seems right with my graph problem.
But why -h all would delete the graphs is beyond my understanding.

So for the time being i’ll remove that row from cron and rediscovering the devices that doesn’t work.

-h all means to discovery all devices.

Ok. Run a discovery.php -d -h iosxedevice -m sensors and look for deleted sensors in the output.

Dont recommend doing that.

1 Like

I got the output of “./discovery.php -d -h all -m sensors” and it showed the sensors being deleted from the same affected host I posted earlier. After this ran, the sensors were all deleted again. Running the discovery without “-h all” and just a specific host will make the sensors get rediscovered but won’t delete them.

Here’s the output:

Does this fix the issue?

It appears this fixed it for me. Thank you!

A post was split to a new topic: Graphs not working

please start a new thread