Problem with lsi snmp agent

i have many servers with lsi snmp agnet installed on them, when i add same device to observium it works and it detect lsi storage and show status of arrays but when i add same servers to librenms it does not detectd storage and array status.
i run validate.php all settings was ok. then i run ./discovery.php -h HOSTNAME -d -m storage i see i have no timedout. the discovery was around 2-3seconds.
so whats wrong and how can i solve this?

I don’t think the agent here shows that kind of data.

What device OS is this? Have you tried the other applications? Like maybe SMART drive monitor in the docs?

yes i tried enable smart but it does not work.
os for both servers are centos.
and when i telnet yo agent it shows megaraid status but i do not know why it does not show in application

Like I said I don’t think anybody has programmed what to do with the data.

so your mean is there no way to fetch lsi raid status in librenms ?
because its really important for us as observium has this

Ok this is not oberservuim and I understand you need that but going around demanding that you get is not how this works… Everything in librenms is community driven all volunteer time and code nobody has added that.

i told observium that explain it had it an i know librenms is not observium, so there is no way for fix this?

Like I said … somebody from the open community would have to contribute time and code for this.

can you help me if we can find any developer that can do this for us as freelancer?

Hey. So I also monitor some LSI megaraids but not natively through librenms. Are you interested in just monitoring the raid health? So I use an snmp_extend service that runs a script that checks the raid status. At least this way you can generate alerts if there are any changes.

Very heavy handed way of doing it but it does work. I could venture into contributing some code but I’d love to know how it should really work. Probably a question for a more senior developer.