Problems after auto update 11/16

Greetings, after the 11/16/2021 update, 3 different librenms installations stopped collecting some devices, anyone with the same problem? I also couldn’t log in with my old account here in the community (through facebook).

Erro in validate config

I used this post: Database: incorrect column error

I can log into Mysql but I can’t run the commands

  • SET TIME_ZONE=’+00:00’;
  • ALTER TABLE notifications CHANGE datetime datetime timestamp NOT NULL DEFAULT ‘1970-01-02 00:00:00’ ;
  • ALTER TABLE users CHANGE created_at created_at timestamp NOT NULL DEFAULT ‘1970-01-02 00:00:01’ ;

Looks the same here… tried again with the SQL commands and it works now as far as I can see. But it did say to everything that no rows affected…

1 Like

I did it, I was typing the command in the wrong Mysql. Thanks

There was a bad commit, the commit was reverted and even figured out what the issue was.

Ok. Is ithis version?

Version 21.11.0-11-g1752d1efd - Tue Nov 16 2021 23:59:46 GMT+0100
Database Schema 2021_11_12_123037_change_cpwVcID_to_unsignedInteger (225)

I’m seeing some odd data like faulty location, sensors deleted etc

what has to be done to ga back to normal?

Run again?

I have no issues in my validate.php but some devices lost all sensors and some locations changed to “Rack, Room, Building, City, County”
I cannot rediscover device if i try to
Devices are showing wrong proccessor graph or same graph across several devices

Anybody else having these issues?

Because all devices were polling your local librenms server snmpd. Hurray for overwrite_ip!

Yes, all you needed to do was run ./

1 Like

I have the issue as well.

tried with SESSION_LIFETIME=35793 in .env file, ./, ./, but my poller still takes 1800secs and ui won’t work correctly. So seems to be the same issue

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.