Proxmox Application not working?

Hi, I just added proxmox like shown here: Applications - LibreNMS Docs

However, it just looks like this:

any idea why?

i use proxmox 5.0-23

You are trying to use sudo but the user requires a password to do so, you’ll need to setup password less sudo.

God, thats why I never use sudo.
So I did this:

I looked into /etc/default/snmpd to see which user snmp is executed as.
Then do “visudo” and add the following line


in my case Debian-snmp is the username

But the proxmox application still looks the same after over an hour…
I also tested this by creating a new user and add this user to visudo list, that worked, no password needed.

1 Like

If you still get the same message at the top like before, it’s still a sudo issue.

Even If i run snmp as root, the message is still the same.
it seems like it’s stuck there and does not not execute the proxmox file.
normally, i’d see in auth.log that the snmp service used sudo, but thats not the case anymore.
So i guess the file is not even executed anymore.

So, yesterday this appeared in the log:

2017-09-11 18:36:35 Application disabled by discovery: proxmox