Python3 (3.6) and pip3 () versions do not match

Good day, I have an error on the Validate Config page of our librenms.

Fail: python3 (3.6) and pip3 () versions do not match. This likely will cause dependencies to be installed for the wrong python version.

I tried the command “apt install python3-pip” and the “python3 -m pip install -r /opt/librenms/requirement.txt” just in case in would fix the issue but it doesn’t. I also read some articles before posting this topic but it does not solve my issue. I’m not a Linux guy so I would appreciate any help. Thank you guys. Keep safe!

Hi? anyone?

hmm, seems like you don’t have pip installed. This is ok as long as the dependencies are met. Seems like a bug in this new validation.

Hi, thanks for your response.
I tried to install pip3 using this command = “apt-get install python3-pip” and this is just the result of it

Reading package lists… Done
Building dependency tree
Reading state information… Done
python3-pip is already the newest version (9.0.1-2.3~ubuntu1.18.04.1).
0 upgraded, 0 newly installed, 0 to remove and 154 not upgraded.