Route polling always on

I have a bunch of cisco devices and they are constantly polling routing table, IE:
. = IpAddress: xx.xx.0.0
. = IpAddress: xx.xx.64.0
. = IpAddress: xx.xx.65.0
. = IpAddress: xx.xx.66.0
. = IpAddress: xx.xx.67.0
. = IpAddress: xx.xx.68.0

and no matter what poller i shut off or even set with LNMS config command, it will not do anything and continues to scan… Any thoughts?

Off the top of my head I would look into excluding those OIDs from the snmp view on the device(s).

thought that too but its not just one brand its several actually. Know how to set which mib lnms uses on select devices?

Hi these are the OIDs that are providing the routing table. More or less “show ip route” but over snmp.
It means you probably have “route” discovery module enabled. Can you check ?

What’s wrong with these SNMP requests in the 1st time ?

you don’t set a MIB or another, you enable modules and LibreNMS will use whatever mib is needed in order to do the job, as far as this device is known and properly supported. If not, LibreNMS may try multiple OIDs in the discovery process (this one is not time constrained) until it eventually finds one that provides the data.
And of course, for unsupported devices (or not well supported) you are more than welcome to submit a patch.

doenst matter if i have route discovery on or off it sill snmpgets all the ip addresses. I dont need it to do that at all. i have turned off all pollers and all discovery mods on one device or another and it still gets all the IP’s its making the poll take above 4 min usually

Your LibreNMS instance looks broken in some way. Does it validate correctly ? Any issue? Is it up to date ?

If yes, you’ll need to anaylse the poller logs (verbose, and may be verbose+debug) to check what’s going on.

it validates fine no isses everything is good and updated nightly system has an over abundance of resources.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.