Rrd graphs showing title w/o spaces

In the past day or so, all our RRDtool based graphs have started displaying a different and somewhat munged title. I can’t recall what it looked like before and don’t have a screenshot, but all our graphs have started showing the graph title with non alphanumeric characters stripped. (No dots, no spaces, etc)

An example is attached.

validate output below.

It definitely wasn’t doing this a couple days ago.

[[email protected] librenms]$ ./validate.php

Component Version
LibreNMS 22.10.0-42-g4b65dc4 (2022-10-28T06:06:29-07:00)
DB Schema 2022_08_15_084507_add_rrd_type_to_wireless_sensors_table (248)
PHP 8.1.11
Python 3.6.8
Database MariaDB 10.5.17-MariaDB
RRDTool 1.7.2
SNMP 5.7.2
===========================================

[OK] Composer Version: 2.4.3
[OK] Dependencies up-to-date.
[OK] Database connection successful
[OK] Database Schema is current
[OK] SQL Server meets minimum requirements
[OK] lower_case_table_names is enabled
[OK] MySQL engine is optimal
[OK]
[OK] Database schema correct
[OK] MySQl and PHP time match
[OK] Active pollers found
[OK] Dispatcher Service not detected
[OK] Locks are functional
[OK] Python poller wrapper is polling
[OK] Redis is unavailable
[OK] rrdtool version ok
[OK] Connected to rrdcached

In case it isn’t obvious, this actual hostname is cr2.sea1.semaphore.net.

If I select, say, Bits as the graph I’m looking at, the graph has the title “cr2sea1semaphorenetbits”

same problem, but today helped me ./daily.sh

Yep, looks like it got fixed overnight.

Nothing to see here! =)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.