RRD Graphs with variable time frame shows still the same time range since Version 1.54-64

Hi Community,

since Update to LibreNMS Version "1.54-64-ga0ba412d6" we recognize a not proper working of Dashboard graphs with variable timeframe (24h ago, 48h ago, 1 week ago…). All graphs shows still the same time range beginning from midnight and not the requested timeframe which is handover in URL (lazy_w=552&from=end-24h)

URLs:

**24h**: https://librenms/graph.php?device=1&type=service_graph&id=95&ds=uptime&lazy_w=552&from=end-24h&legend=yes&[email protected][email protected]&[email protected][email protected]
**48h**: https://librenms/graph.php?device=1&type=service_graph&id=95&ds=uptime&lazy_w=552&from=end-48h&legend=yes&[email protected][email protected]&[email protected][email protected]
**last week**: https://librenms/graph.php?device=1&type=service_graph&id=95&ds=uptime&lazy_w=552&from=end-168h&legend=yes&[email protected][email protected]&[email protected][email protected]
**last month**: https://librenms/graph.php?device=1&type=service_graph&id=95&ds=uptime&lazy_w=552&from=end-1m&legend=yes&[email protected][email protected]&[email protected][email protected]

Graphs still shows the same time frame:

When I use absolute time ranges (fix time range) then it shows me the correct time frame:

URLs:

> **6h**:https://librenms/graphs/device=1/type=service_graph/id=95/ds=uptime/from=1567132200/to=1567153800/
> **24h**:https://librenms/graphs/device=1/type=service_graph/id=95/ds=uptime/from=1567067400/to=1567153800/
> **48h**:https://librenms/graphs/device=1/type=service_graph/id=95/ds=uptime/from=1566981000/to=1567153800/
> ...

When I change the time frame in URL from absolute e.g. “from=1566981000/to=1567153800/” range to variable e.g. 96h “lazy_w=552&from=end-96h” it still shows me only the last 24h instead of requested 96h.

The same happens for all graphs in LibreNMS Android App (IOS not tested)
Here an example for CPU processor graph and Poller graph:

All graphs shows still the same time frame. :thinking:

I guess it happens since last version update to "1.54-64-ga0ba412d6" and it was never seen before in older version “1.53.1-58-g5400a908f

Here my validate output:

Component Version
LibreNMS 1.54-64-ga0ba412d6
DB Schema 2019_07_09_150217_update_users_widgets_settings (140)
PHP 7.2.9-1+b2
MySQL 10.3.15-MariaDB-1
RRDTool 1.7.1
SNMP NET-SNMP 5.7.3

Can you please investigate that and fix that to make it working as before in the last update.

Thanks in advance,
Chris,

bumping this topic as i would be interested having a relative timestamp that show 24 hours of actual data, like 24 hours ago till now…
and not data showing starting from midnight

LibreNMS | 21.1.0-9-g30c008cc5

We are having the same issue while trying to print 1 week timeframe on the alerts.

I’m pretty sure this has been the behavior since the beginning.

However, this might work:
Edit the url and remove to and change from to 1week or 2day or twoday, or variations of that.

that doesnt work, it always default to 24 hours of data
and the stats will always reset at 0:00 which means if you are look at the graph at 0:01 you only see 1 minute worth of data

This wasnt always the case as 2019 had url that supported 24 hours data, regardless of the time you view the url.

from=-1d is the actual format, see more options: