Run validate.php get error [FIX] Check the cron job to make sure it is running and using discovery-wrapper.py

Hi Guys,

run /opt/librenms/validate.php

get message How do I fix this?
[FAIL] Discovery has not completed in the last 24 hours.
[FIX] Check the cron job to make sure it is running and using discovery-wrapper.py

many thanks.

[[email protected] logs]# /opt/librenms/validate.php

Component Version
LibreNMS 1.33-39-g21495a8
DB Schema 215
PHP 7.0.24
MySQL 5.5.56-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Database connection successful
[OK] Database schema correct
[FAIL] Discovery has not completed in the last 24 hours.
[FIX] Check the cron job to make sure it is running and using discovery-wrapper.py

Did you check your cron entries and cron log?

If you’ve added any ICMP only devices then this was fixed in a commit a short while ago, update and try validate again.

Hi murrant

the cron log not find any error

Nov 8 12:01:01 librenms CROND[20895]: (librenms) CMD ( /opt/librenms/cronic /opt/librenms/poller-wrapper.py 16)
Nov 8 12:01:01 librenms run-parts(/etc/cron.hourly)[20893]: starting 0anacron
Nov 8 12:01:01 librenms run-parts(/etc/cron.hourly)[20910]: finished 0anacron
Nov 8 12:01:01 librenms run-parts(/etc/cron.hourly)[20893]: starting mcelog.cron
Nov 8 12:01:01 librenms run-parts(/etc/cron.hourly)[20917]: finished mcelog.cron
Nov 8 12:02:01 librenms CROND[25791]: (librenms) CMD ( /opt/librenms/alerts.php >> /dev/null 2>&1)
Nov 8 12:02:01 librenms CROND[25792]: (librenms) CMD ( /opt/librenms/cronic /opt/librenms/poller-wrapper.py 16)
Nov 8 12:03:01 librenms CROND[30880]: (librenms) CMD ( /opt/librenms/alerts.php >> /dev/null 2>&1)
Nov 8 12:03:01 librenms CROND[30881]: (librenms) CMD ( /opt/librenms/cronic /opt/librenms/poller-wrapper.py 16)
Nov 8 12:04:01 librenms CROND[35716]: (librenms) CMD ( /opt/librenms/alerts.php >> /dev/null 2>&1)
Nov 8 12:04:01 librenms CROND[35717]: (librenms) CMD ( /opt/librenms/cronic /opt/librenms/poller-wrapper.py 16)

[[email protected] librenms]# more /etc/cron.d/librenms

Using this cron file requires an additional user on your system, please see install docs.

33 */6 * * * librenms /opt/librenms/discovery.php -h all >> /dev/null 2>&1
*/5 * * * * librenms /opt/librenms/discovery.php -h new >> /dev/null 2>&1
*/1 * * * * librenms /opt/librenms/cronic /opt/librenms/poller-wrapper.py 16
15 0 * * * librenms /opt/librenms/daily.sh >> /dev/null 2>&1

          • librenms /opt/librenms/alerts.php >> /dev/null 2>&1
            */5 * * * * librenms /opt/librenms/poll-billing.php >> /dev/null 2>&1
            01 * * * * librenms /opt/librenms/billing-calculate.php >> /dev/null 2>&1
            */5 * * * * librenms /opt/librenms/check-services.php >> /dev/null 2>&1

@glen - Update and try validate again

hi laf

Can you provide a way to update?

thanks.

Run . /daily.sh

Hi Kevin_Krumm

I have run . /daily.sh
Still have the wrong message
[[email protected] librenms]# ./daily.sh
Re-running /opt/librenms/daily.sh as librenms user
Checking PHP version OK
Updating to latest codebase OK
Updated from 5ad28c920248106677170d893a06c8cbf929f2d1 to 0c49e9b0232c1c0fcbd3b39176adf99e26fe825c OK
Updating SQL-Schema OK
Updating submodules OK
Cleaning up DB OK
Fetching notifications OK
Caching PeeringDB data OK
[[email protected] librenms]# ./validate.php

Component Version
LibreNMS 1.33-89-g0c49e9b
DB Schema 215
PHP 7.0.24
MySQL 5.5.56-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

====================================

[OK] Database connection successful
[OK] Database schema correct
[FAIL] Discovery has not completed in the last 24 hours.
[FIX] Check the cron job to make sure it is running and using discovery-wrapper.py

Run this in mysql:

SELECT hostname FROM devices WHERE last_discovered <= DATE_ADD(NOW(), INTERVAL - 24 HOUR) AND ignore = 0 AND disabled = 0 AND status = 1 AND snmp_disable = 0;

That will show you the hostnames of devices that haven’t completed in the last 24 hours. Run ./discovery.php -h HOSTNAME and see how long it takes to run

3 posts were split to a new topic: Discovery not running