Scripts/composer_wrapper.php install --no-dev & proxy 407 error

Hi all.
Like so many others, my LibreNMS installation broke last week.
Initially, I could not run ‘composer_wrapper.php install --no-dev’ and had to install mbstring modules. Now, I’m getting error 407 from my proxy server

The output of validate.php is also broken and now complains about

PHP Warning: require(/opt/librenms/vendor/composer/…/guzzlehttp/guzzle/src/functions_include.php): failed to open stream: No such file or directory

Any ideas?

Is your proxy allowing https access to github? Looks like it might not.

Yes it does. I have also configured the .git/config file with the correct proxy credentials and set the environment variables.



export HTTP_PROXY_REQUEST_FULLURI=0 # or false

Thanks laf.
That didn’t work either.

Most likely because my HTTPS proxy wants an http:// URI instead of an https:// URI. I have to drop the S in HTTPS for my proxy settings.

PS I now have a web GUI again.
PPS Do the LibreNMS guys know why so many installations broke? I’ve been using the OVA only for two weeks with a scheduled Nothing added except for devices.

We’ve switched to laravel which turned out needed another php module a lot of people didn’t have, mostly unavoidable but it doesn’t affect data.