Seems rrdcached.sock may be missing

Good morning.
I have been dabbling with rrd / tools and rrdcached. I am not a linux guy so I do fumble through this.
I tried to enable rrdcached this morning and after breaking my graphs, could not find a mentioned rrdcached.sock.
If I did the systemctl status rrdached.service …I got an Active: failed (Result: exit-code) message.
Doing a which rrdcached shows path to /usr/bin/rrdcached which seems to jive with my configs. So I am a little perplexed. I edited out my $config[‘rrdcached’] for now in config.php

Thoughts please and thank you

Have you made sure you’ve installed RRDCached correctly? We have some docs on how to do that: RRDCached - LibreNMS Docs

Thanks Laf. Revisiting that document again. I’ve updated rrdtool on my CentOS. I’ll update after I double check everything. Thanks for your assistance
On another note it appears I have 1.7.0 Is it necessary to have the $config statement in config.php with version of my rrdtool?

Terry

You still need to configure the rrdcached details within the Webui now. Global Settings → Poller → Datastore: RRDTool

10 4 We run commercial pollers for our HFC and FTTx plants - the Librenms was a personal project just to monitor core equipment and utilize it’s network mapping options. I don’t have much experience with the rrdtools or linux so it’s been fun, frustrating and a learning experience. Apparently as stated, 1.7.0 is the version of rrdtools. The only damn thing I can’t track down is that rrdcached.sock. I’ll update today when I get a chance to tinker.
Thank you again
Terry

Depending on your OS, it’s literally in our rrdcached install docs: ExecStart=/usr/bin/rrdcached -w 1800 -z 1800 -f 3600 -s librenms -U librenms -G librenms -B -R -j /var/tmp -l unix:/run/rrdcached.sock -t 4 -F -b /opt/librenms/rrd/

So in that example (CentOS 7/8) it’s /run/rrdcached.sock